summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD23
2 files changed, 20 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0429298e6bcc..baf45fd54b6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,25 @@
pkgbase = emacs-application-framework-git
pkgdesc = EAF extends GNU Emacs to an entire universe of powerful GUI applications.
- pkgver = r1908.b21efed
+ pkgver = r2086.4b5d4294
pkgrel = 1
url = https://github.com/manateelazycat/emacs-application-framework
arch = any
license = GPL3
makedepends = git
- depends = emacs
- depends = python-epc
+ makedepends = nodejs
+ makedepends = npm
depends = python-pyqt5
depends = python-pyqt5-sip
depends = python-pyqtwebengine
depends = wmctrl
- depends = nodejs
- optdepends = python-pymupdf: EAF PDF Viewer support
- optdepends = python-qrcode: EAF File Sender/File Receiver/Airshare support
- optdepends = libreoffice: EAF Doc Viewer support
- optdepends = filebrowser-bin: EAF File Browser support
- optdepends = python-qtconsole: EAF Jupyter support
- optdepends = python-retrying: EAF Markdown Previewer support
+ depends = python-qrcode
+ depends = aria2
+ depends = python-qtconsole
+ depends = taglib
+ depends = filebrowser-bin
provides = emacs-eaf
conflicts = emacs-eaf
source = git+https://github.com/manateelazycat/emacs-application-framework
md5sums = SKIP
pkgname = emacs-application-framework-git
-
diff --git a/PKGBUILD b/PKGBUILD
index e2e0108f08cc..8b0371ad0881 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,16 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>, Mingde (Matthew) Zeng <matthewzmd@posteo.net>
pkgname=emacs-application-framework-git
-pkgver=r1908.b21efed
+pkgver=r2086.4b5d4294
pkgrel=1
pkgdesc="EAF extends GNU Emacs to an entire universe of powerful GUI applications."
arch=('any')
url="https://github.com/manateelazycat/emacs-application-framework"
license=('GPL3')
-depends=('emacs' 'python-epc' 'python-pyqt5' 'python-pyqt5-sip' 'python-pyqtwebengine' 'wmctrl' 'nodejs')
-optdepends=('python-pymupdf: EAF PDF Viewer support'
- 'python-qrcode: EAF File Sender/File Receiver/Airshare support'
- 'libreoffice: EAF Doc Viewer support'
- 'filebrowser-bin: EAF File Browser support'
- 'python-qtconsole: EAF Jupyter support'
- 'python-retrying: EAF Markdown Previewer support')
-makedepends=('git')
+makedepends=('git' 'nodejs' 'npm')
+depends=('python-pyqt5' 'python-pyqt5-sip' 'python-pyqtwebengine' 'wmctrl'
+ 'python-qrcode' 'aria2' 'python-qtconsole' 'taglib'
+ 'filebrowser-bin')
provides=('emacs-eaf')
conflicts=('emacs-eaf')
source=("git+https://github.com/manateelazycat/emacs-application-framework")
@@ -29,9 +25,14 @@ pkgver() {
package() {
cd "${pkgname%-git}"
install -d "$pkgdir"/usr/share/emacs/site-lisp/eaf/
- for _i in app core docker *.el *.py
+ for _i in LICENSE app core docker *.el *.py *.js *.sh package.json
do
cp -r ${_i} "$pkgdir"/usr/share/emacs/site-lisp/eaf/
done
- install -Dm644 README.md "$pkgdir"/usr/share/doc/emacs-eaf/README.md
+ install -Dm644 README.md "$pkgdir"/usr/share/doc/emacs-application-framework-git/README.md
+ install -Dm644 README.zh-CN.md "$pkgdir"/usr/share/doc/emacs-application-framework-git/README.zh-CN.md
+
+ cd "$pkgdir"/usr/share/emacs/site-lisp/eaf && ./install-eaf.sh --ignore-sys-deps
+
+ echo "Installation complete, please add $pkgdir/usr/share/emacs/site-lisp/eaf/ to your load-path."
}