summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 099f467bbc1f..08d76f68e7e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Mon Jun 19 18:16:07 UTC 2017
pkgbase = emacs-epc
pkgdesc = An RPC stack for Emacs Lisp
pkgver = 0.1.1
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/kiwanami/emacs-epc
arch = any
license = GPL3
@@ -13,7 +11,7 @@ pkgbase = emacs-epc
depends = python-epc
depends = emacs-deferred
provides = emacs-epc
- source = https://github.com/kiwanami/emacs-epc/archive/0.1.1.tar.gz
+ source = emacs-epc-0.1.1.tar.gz::https://github.com/kiwanami/emacs-epc/archive/0.1.1.tar.gz
sha256sums = SKIP
pkgname = emacs-epc
diff --git a/PKGBUILD b/PKGBUILD
index e5bc72699f35..edca18581e2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+# Contributor: Alex Whitt <alex.joseph.whitt@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=emacs-epc
pkgver=0.1.1
-pkgrel=3
+pkgrel=4
pkgdesc="An RPC stack for Emacs Lisp"
url="https://github.com/kiwanami/emacs-epc"
arch=('any')
@@ -10,16 +11,16 @@ license=('GPL3')
depends=('emacs' 'emacs-ctable' 'python-epc' 'emacs-deferred')
makedepends=('git')
provides=('emacs-epc')
-source=("https://github.com/kiwanami/emacs-epc/archive/${pkgver}.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/kiwanami/emacs-epc/archive/${pkgver}.tar.gz")
sha256sums=('SKIP')
build() {
- cd "${srcdir}/emacs-epc-${pkgver}"
+ cd emacs-epc-${pkgver}
emacs -q --no-splash -batch -L . -f batch-byte-compile epc*.el
}
package() {
- cd "${srcdir}/emacs-epc-${pkgver}"
- install -d "${pkgdir}/usr/share/emacs/site-lisp/epc"
- install -m644 epc*.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/epc/"
+ cd emacs-epc-${pkgver}
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/epc
+ install -m644 epc*.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/epc/
}