summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7c9cfad7c0e7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Tue Apr 25 19:50:35 UTC 2017
+pkgbase = emacs-font-lock-plus
+ pkgdesc = Enhancements to standard library 'font-lock.el'.
+ pkgver = 208
+ pkgrel = 1
+ url = https://www.emacswiki.org/emacs/font-lock%2B.el
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = emacs
+ provides = emacs-font-lock-plus
+ source = https://github.com/emacsmirror/font-lock-plus/archive/208.tar.gz
+ sha256sums = SKIP
+
+pkgname = emacs-font-lock-plus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..20a91abe5da4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+
+pkgname=emacs-font-lock-plus
+pkgver=208
+pkgrel=1
+pkgdesc="Enhancements to standard library 'font-lock.el'."
+url="https://www.emacswiki.org/emacs/font-lock%2B.el"
+arch=('any')
+license=('GPL2')
+depends=('emacs')
+makedepends=('git')
+provides=('emacs-font-lock-plus')
+source=("https://github.com/emacsmirror/font-lock-plus/archive/${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}/font-lock-plus-${pkgver}"
+ emacs -Q -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "${srcdir}/font-lock-plus-${pkgver}"
+ install -d "${pkgdir}/usr/share/emacs/site-lisp/font-lock-plus/"
+ install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/font-lock-plus/"
+}