summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8c178063a7b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = emacs-graphql-git
+ pkgdesc = GraphQL utilities
+ pkgver = r53.b64ab8d
+ pkgrel = 1
+ url = https://github.com/vermiculus/graphql.el
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ provides = emacs-graphql
+ conflicts = emacs-graphql
+ source = git+https://github.com/vermiculus/graphql.el.git
+ sha256sums = SKIP
+
+pkgname = emacs-graphql-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c92e687acaa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+_gituser="vermiculus"
+_gitrepo="graphql.el"
+
+pkgname=emacs-graphql-git
+pkgver=r53.b64ab8d
+pkgrel=1
+pkgdesc="GraphQL utilities"
+url="https://github.com/${_gituser}/${_gitrepo}"
+arch=('any')
+license=('GPL3')
+depends=('emacs')
+makedepends=('git')
+provides=('emacs-graphql')
+conflicts=('emacs-graphql')
+source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitrepo"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_gitrepo"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "$_gitrepo"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/graphql/
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/graphql/
+}