summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
-rw-r--r--emacs-guide-key.install21
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..89b802cf934c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Thu May 11 17:00:22 UTC 2017
+pkgbase = emacs-guide-key
+ pkgdesc = Guide following keys to an input key sequence automatically and dynamically in Emacs.
+ pkgver = 1.2.5
+ pkgrel = 1
+ url = https://github.com/kai2nenobu/guide-key
+ install = emacs-guide-key.install
+ arch = any
+ license = GPL3
+ depends = emacs
+ depends = emacs-dash
+ depends = emacs-s
+ depends = emacs-popwin
+ source = emacs-guide-key-1.2.5.tar.gz::https://github.com/kai2nenobu/guide-key/archive/v1.2.5.tar.gz
+ sha256sums = b090bde7f6ee06a2f4d1773496387759962475b62870f99102850167648a4c99
+
+pkgname = emacs-guide-key
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..968a8d09352a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+
+_pkgsrcname=guide-key
+_pkgmaintainer=kai2nenobu
+_pkgdestdirname=guide-key
+_versionprefix=v
+pkgver=1.2.5
+pkgrel=1
+pkgdesc="Guide following keys to an input key sequence automatically and dynamically in Emacs."
+pkgname=emacs-${_pkgdestdirname}
+arch=(any)
+url="https://github.com/${_pkgmaintainer}/${_pkgsrcname}"
+license=('GPL3')
+depends=('emacs' 'emacs-dash' 'emacs-s' 'emacs-popwin')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/${_pkgmaintainer}/${_pkgsrcname}/archive/${_versionprefix}${pkgver}.tar.gz")
+sha256sums=('b090bde7f6ee06a2f4d1773496387759962475b62870f99102850167648a4c99')
+install=${pkgname}.install
+
+build() {
+ cd "${srcdir}/${_pkgsrcname}-${pkgver}"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "${srcdir}/${_pkgsrcname}-${pkgver}"
+ mkdir -p "${pkgdir}/usr/share/emacs/site-lisp/${_pkgdestdirname}/"
+ install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/${_pkgdestdirname}/"
+}
diff --git a/emacs-guide-key.install b/emacs-guide-key.install
new file mode 100644
index 000000000000..c21b6701aa03
--- /dev/null
+++ b/emacs-guide-key.install
@@ -0,0 +1,21 @@
+post_install () {
+
+cat << EOF
+
+==> Add this code to your .emacs file to use the mode:
+
+(require 'guide-key)
+(guide-key-mode 1)
+
+==> Or, with use-package:
+
+(use-package guide-key
+ :config
+ (guide-key-mode 1))
+
+EOF
+}
+
+post_upgrade () {
+ post_install $1
+}