summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd74d3f09e1d..e7644311e242 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = emacs-jedi
pkgdesc = Python auto-completion for Emacs
- pkgver = 0.2.7
- pkgrel = 4
+ pkgver = 0.2.8
+ pkgrel = 1
url = https://github.com/tkf/emacs-jedi
arch = any
license = GPL3
@@ -13,8 +13,8 @@ pkgbase = emacs-jedi
depends = emacs-python-environment
depends = python-virtualenv
provides = emacs-jedi
- source = emacs-jedi-0.2.7.zip::https://github.com/tkf/emacs-jedi/archive/master.zip
- sha256sums = 4adff270a37ee3a1757d0b7947d904bd2f88118db571f608c571363afe8315dc
+ source = emacs-jedi-0.2.8.tar.gz::https://github.com/tkf/emacs-jedi/archive/v0.2.8.tar.gz
+ sha256sums = f97884ef3016146a0f0323e23b348066a253cbe780f03e952a209fd96aa4bcd9
pkgname = emacs-jedi
diff --git a/PKGBUILD b/PKGBUILD
index aa087355eb41..4da62ff8551e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=emacs-jedi
-pkgver=0.2.7
-pkgrel=4
+pkgver=0.2.8
+pkgrel=1
pkgdesc="Python auto-completion for Emacs"
url="https://github.com/tkf/emacs-jedi"
arch=('any')
@@ -11,16 +11,16 @@ license=('GPL3')
depends=('emacs' 'python-jedi' 'emacs-auto-complete' 'emacs-epc' 'emacs-python-environment' 'python-virtualenv')
makedepends=('git')
provides=('emacs-jedi')
-source=("$pkgname-$pkgver.zip::https://github.com/tkf/emacs-jedi/archive/master.zip")
-sha256sums=('4adff270a37ee3a1757d0b7947d904bd2f88118db571f608c571363afe8315dc')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/tkf/emacs-jedi/archive/v$pkgver.tar.gz")
+sha256sums=('f97884ef3016146a0f0323e23b348066a253cbe780f03e952a209fd96aa4bcd9')
build() {
- cd emacs-jedi-master
+ cd emacs-jedi-$pkgver
emacs -q --no-splash -batch -L . -f batch-byte-compile jedi*.el
}
package() {
- cd emacs-jedi-master
+ cd emacs-jedi-$pkgver
install -d "$pkgdir"/usr/share/emacs/site-lisp/jedi
install -m644 jedi*.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/jedi/
install -m755 jedi*.py "$pkgdir"/usr/share/emacs/site-lisp/jedi/