summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
-rw-r--r--emacs-lll-mode-git.install14
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b661b6ae3e85
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = emacs-lll-mode-git
+ pkgdesc = An emacs major mode for editing Ethereum LLL code
+ pkgver = v0.1.0.r0.gdecc55c
+ pkgrel = 1
+ url = https://github.com/robmyers/lll-mode
+ install = emacs-lll-mode-git.install
+ arch = x86_64
+ license = GPLv3
+ makedepends = git
+ depends = emacs
+ provides = emacs-lll-mode
+ conflicts = emacs-lll-mode
+ source = emacs-lll-mode-git::git+https://gitlab.com/veox/emacs-lll-mode.git
+ md5sums = SKIP
+
+pkgname = emacs-lll-mode-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..81f79f67cc27
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Noel Maersk <veox plus packages the veox toad pw>
+
+pkgname=emacs-lll-mode-git
+pkgver=v0.1.0.r0.gdecc55c
+pkgrel=1
+pkgdesc='An emacs major mode for editing Ethereum LLL code'
+arch=('x86_64')
+url='https://github.com/robmyers/lll-mode'
+license=('GPLv3')
+makedepends=('git')
+depends=('emacs')
+install=${pkgname}.install
+provides=('emacs-lll-mode')
+conflicts=('emacs-lll-mode')
+source=("$pkgname"::'git+https://gitlab.com/veox/emacs-lll-mode.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ # cutting off 'v-' prefix that presents in the git tag
+ git describe --long | sed 's/^v-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ mkdir -p $pkgdir/usr/share/emacs/site-lisp/lll-mode
+ install -Dm644 *.el $pkgdir/usr/share/emacs/site-lisp/lll-mode
+}
diff --git a/emacs-lll-mode-git.install b/emacs-lll-mode-git.install
new file mode 100644
index 000000000000..ec75e02b8202
--- /dev/null
+++ b/emacs-lll-mode-git.install
@@ -0,0 +1,14 @@
+post_install() {
+ cat <<EOF
+==> Add this code to your Emacs init to use markdown-mode:
+
+(autoload 'lll-mode "lll-mode.el" "Major mode for editing LLL files" t)
+(setq auto-mode-alist (append '(("\\.lll$" . lll-mode)) auto-mode-alist))
+
+EOF
+}
+
+
+post_upgrade() {
+ post_install $1
+}