summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e4600d64bab..e7b943affaac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
pkgbase = emacs-magit-popup
pkgdesc = A generic interface for toggling switches and setting options and then invoking an Emacs command which does something with these arguments
- pkgver = 2.13.0
+ pkgver = 2.13.3
pkgrel = 1
url = http://github.com/magit/magit-popup
install = emacs-magit-popup.install
arch = any
license = GPL3
- makedepends = git
- depends = emacs>=24.4
+ depends = emacs
depends = emacs-dash>=2.13.0
- depends = emacs-async>=1.9.2
+ depends = emacs-async
provides = emacs-magit-popup
conflicts = emacs-magit<=2.11.0
- source = git+https://github.com/magit/magit-popup.git#tag=v2.13.0
- md5sums = SKIP
+ source = https://github.com/magit/magit-popup/archive/refs/tags/v2.13.3.tar.gz
+ sha256sums = b15e206530f7bd3d434ac6b45342b16c23783bf6defea77ecc500ee2e4a9c4c5
pkgname = emacs-magit-popup
-
diff --git a/PKGBUILD b/PKGBUILD
index 6db495dbb6f5..77f6a46b0a02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,32 @@
+# Maintainer: hamki <hamki.do2000@gmail.com>
# Maintainer: Esben Haabendal <esben@haabendal.dk>
pkgname=emacs-magit-popup
_github_org="magit"
_github_repo="magit-popup"
-pkgver=2.13.0
+pkgver=2.13.3
pkgrel=1
pkgdesc="A generic interface for toggling switches and setting options and then invoking an Emacs command which does something with these arguments"
arch=('any')
url="http://github.com/${_github_org}/${_github_repo}"
license=('GPL3')
-depends=('emacs' 'emacs-dash>=2.13.0' 'emacs-async>=1.9.2')
-makedepends=('git')
+depends=('emacs' 'emacs-dash>=2.13.0' 'emacs-async')
+makedepends=()
provides=('emacs-magit-popup')
conflicts=('emacs-magit<=2.11.0')
install="${pkgname}.install"
-source=("git+https://github.com/${_github_org}/${_github_repo}.git#tag=v${pkgver}")
-md5sums=('SKIP')
+source=("https://github.com/${_github_org}/${_github_repo}/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('b15e206530f7bd3d434ac6b45342b16c23783bf6defea77ecc500ee2e4a9c4c5')
build() {
- cd "$srcdir/${_github_repo}"
+ cd "$srcdir/${_github_repo}-${pkgver}"
unset EMACS
make LOAD_PATH="-L /usr/share/emacs/site-lisp" \
lisp info
}
package() {
- cd "$srcdir/${_github_repo}"
+ cd "$srcdir/${_github_repo}-${pkgver}"
mkdir -p ${pkgdir}/usr/share/emacs/site-lisp
install -m 644 magit-popup.{el,elc} ${pkgdir}/usr/share/emacs/site-lisp
mkdir -p ${pkgdir}/usr/share/info