summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
2 files changed, 17 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe56ccd97846..2e729e3a1aa6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
-# Generated by makepkg 4.2.1
-# Wed Jun 10 12:40:46 UTC 2015
+# Generated by makepkg 5.0.1
+# Fri Dec 16 11:24:51 UTC 2016
pkgbase = emacs-multiple-cursors
pkgdesc = Multiple cursors for Emacs
- pkgver = 1.3.0
- pkgrel = 2
+ pkgver = 1.4.0
+ pkgrel = 1
url = https://github.com/magnars/multiple-cursors.el
install = emacs-multiple-cursors.install
arch = any
license = GPL3
depends = emacs
- source = https://github.com/magnars/multiple-cursors.el/archive/1.3.0.tar.gz
- md5sums = b60faec04a10f911289cf40828c4ac80
+ source = https://github.com/magnars/multiple-cursors.el/archive/1.4.0.tar.gz
+ sha256sums = 33a1c193cf8bcb0c80f71a154cbbc1956ee80a79ec63ebcaf3ea6fb6298c3042
pkgname = emacs-multiple-cursors
diff --git a/PKGBUILD b/PKGBUILD
index 4fec3bb7be03..4d3fc4f194a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,26 @@
pkgname=emacs-multiple-cursors
_pkgname=multiple-cursors
-pkgver=1.3.0
-pkgrel=2
+pkgver=1.4.0
+pkgrel=1
pkgdesc="Multiple cursors for Emacs"
-arch=('any')
+arch=("any")
url="https://github.com/magnars/multiple-cursors.el"
-license=('GPL3')
+license=("GPL3")
install=$pkgname.install
-depends=('emacs')
+depends=("emacs")
source=("https://github.com/magnars/$_pkgname.el/archive/$pkgver.tar.gz")
-md5sums=('b60faec04a10f911289cf40828c4ac80')
+sha256sums=('33a1c193cf8bcb0c80f71a154cbbc1956ee80a79ec63ebcaf3ea6fb6298c3042')
build() {
cd $srcdir/$_pkgname.el-$pkgver/
- emacs -batch -f batch-byte-compile *.el
+ for file in $(find . -maxdepth 1 -type f -name '*.el'); do
+ emacs -Q --batch --eval "(progn (load-file \"multiple-cursors-core.el\")(load-file \"mc-mark-more.el\")(byte-compile-file \"${file}\"))"
+ done
}
+
+
package() {
cd $srcdir/$_pkgname.el-$pkgver/
install -d -m755 $pkgdir/usr/share/emacs/site-lisp/multiple-cursors