summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD12
2 files changed, 3 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 71d9f72107d7..e259bcc6da1b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -17,7 +17,6 @@ pkgbase = emacs-native-comp-git-enhanced
depends = libxml2
depends = jansson
depends = harfbuzz
- depends = libgccjit
depends = gtk3
depends = libjpeg-turbo
depends = giflib
diff --git a/PKGBUILD b/PKGBUILD
index 7aaa18d7476c..c895690b4e07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -48,7 +48,9 @@ MOLD="YES" # Use the mold linker.
# This is the default linker.
# Notice that it will always be used.
-JIT="YES" # Enable native just-in-time compilation. libgccjit is in AUR.
+JIT="YES" # Enable native just-in-time compilation. Use libgccjit,
+ # which is already included in Arch's gcc package.
+ #
# This compiles only performance critical elisp files.
#
# To compile all elisp on demand, add
@@ -164,14 +166,6 @@ if [[ $CLANG == "YES" ]]; then
fi
fi
-if [[ $JIT == "YES" ]]; then
- if [[ $CLI == "YES" ]]; then
- depends_nox+=( 'libgccjit' );
- else
- depends+=( 'libgccjit' );
- fi
-fi
-
if [[ $CLI == "YES" ]]; then
depends=("${depends_nox[@]}");
elif [[ $NOTKIT == "YES" ]]; then