summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD35
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4f514968c9f6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = emacs-onedark-theme-git
+ pkgdesc = An Emacs port of the Atom One Dark theme.
+ pkgver = r154.623fc08
+ pkgrel = 1
+ url = https://github.com/jonathanchu/atom-one-dark-theme
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ provides = emacs-onedark-theme
+ source = emacs-onedark-theme-git::git://github.com/jonathanchu/atom-one-dark-theme
+ sha256sums = SKIP
+
+pkgname = emacs-onedark-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b34c623271af
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Poscat <poscat@mail.poscat.moe>
+
+pkgname=emacs-onedark-theme-git
+pkgver=r154.623fc08
+pkgrel=1
+pkgdesc="An Emacs port of the Atom One Dark theme."
+arch=('x86_64')
+url="https://github.com/jonathanchu/atom-one-dark-theme"
+license=('GPL3')
+provides=('emacs-onedark-theme')
+conflicts=()
+makedepends=('git')
+depends=('emacs')
+source=("${pkgname}::git://github.com/jonathanchu/atom-one-dark-theme")
+noextract=()
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ git submodule update --init
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ install -D -m 644 atom-one-dark-theme.el "${pkgdir}/usr/share/emacs/site-lisp/onedark-theme/atom-one-dark-theme.el"
+}