summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
-rw-r--r--emacs-sdcv.install13
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..598ea4d4de40
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = emacs-sdcv
+ pkgdesc = An extension to lookup words through sdcv (StarDict Console Version) in Emacs.
+ pkgver = 0.1
+ pkgrel = 3
+ url = http://code.google.com/p/sdcv-mode/
+ install = emacs-sdcv.install
+ arch = any
+ license = GPL
+ depends = emacs
+ depends = sdcv
+ source = http://sdcv-mode.googlecode.com/svn/trunk/sdcv-mode.el
+ md5sums = 3241cda6ba365e9ad9daf0a36b16ae82
+
+pkgname = emacs-sdcv
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc1e373c7c80
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Contributor: gucong <gucong43216@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=emacs-sdcv
+pkgver=0.1
+pkgrel=3
+pkgdesc="An extension to lookup words through sdcv (StarDict Console Version) in Emacs."
+arch=('any')
+url="http://code.google.com/p/sdcv-mode/"
+license=('GPL')
+depends=('emacs' 'sdcv')
+install=$pkgname.install
+source=(http://sdcv-mode.googlecode.com/svn/trunk/sdcv-mode.el)
+md5sums=('3241cda6ba365e9ad9daf0a36b16ae82')
+
+build() {
+ emacs -Q -batch -L . -f batch-byte-compile sdcv-mode.el
+}
+package() {
+ install -D -m 644 "$srcdir/sdcv-mode.el" \
+ "$pkgdir/usr/share/emacs/site-lisp/sdcv-mode.el"
+ install -D -m 644 "$srcdir/sdcv-mode.elc" \
+ "$pkgdir/usr/share/emacs/site-lisp/sdcv-mode.elc"
+}
diff --git a/emacs-sdcv.install b/emacs-sdcv.install
new file mode 100644
index 000000000000..847ed3ae0abc
--- /dev/null
+++ b/emacs-sdcv.install
@@ -0,0 +1,13 @@
+post_install() {
+ cat << EOF
+==> To setup sdcv-mode, put the follow lines to your ~/.emacs:
+ (require 'sdcv-mode)
+ (global-set-key (kbd "C-c d") 'sdcv-search)
+
+EOF
+}
+
+post_upgrade() {
+ post_install $1
+}
+