summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD3
-rw-r--r--emacs-spaceline.install44
3 files changed, 49 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ad3bda366a8..22f0ece9845d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
# Generated by mksrcinfo v8
-# Wed May 3 22:17:18 UTC 2017
+# Thu May 4 16:18:33 UTC 2017
pkgbase = emacs-spaceline
pkgdesc = Powerline theme from Spacemacs
pkgver = 2.0.1
pkgrel = 1
url = https://github.com/TheBB/spaceline
+ install = emacs-spaceline.install
arch = any
license = GPL3
makedepends = git
@@ -27,7 +28,7 @@ pkgbase = emacs-spaceline
optdepends = emacs-evil: Show current Evil state
provides = emacs-spaceline
source = emacs-spaceline-2.0.1.tar.gz::https://github.com/TheBB/spaceline/archive/v2.0.1.tar.gz
- sha256sums = SKIP
+ sha256sums = b060d63b3e3b71b65d0406d5c6e730efb6a7fa95cacc21d0e53f705e44559314
pkgname = emacs-spaceline
diff --git a/PKGBUILD b/PKGBUILD
index ee090d2b4ba0..16d45f40ff3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,7 +24,8 @@ optdepends=("emacs-persp-mode: Show current workspace name"
makedepends=('git')
provides=('emacs-spaceline')
source=("$pkgname-$pkgver.tar.gz::https://github.com/TheBB/spaceline/archive/v${pkgver}.tar.gz")
-sha256sums=('SKIP')
+sha256sums=('b060d63b3e3b71b65d0406d5c6e730efb6a7fa95cacc21d0e53f705e44559314')
+install=${pkgname}.install
build() {
cd "${srcdir}/spaceline-${pkgver}"
diff --git a/emacs-spaceline.install b/emacs-spaceline.install
new file mode 100644
index 000000000000..ca933c3a34b2
--- /dev/null
+++ b/emacs-spaceline.install
@@ -0,0 +1,44 @@
+post_install () {
+
+cat << EOF
+
+==> Add this code to your .emacs file to use the mode:
+
+(require 'spaceline-config)
+(setq powerline-default-separator 'utf-8)
+(spaceline-compile)
+(spaceline-spacemacs-theme)
+
+==> The compile step is included to keep it up-to-date when reloading
+ your .emacs, and can be omitted if desired.
+
+==> Also note that spaceline must be initialized *after* any of its
+ optional dependencies!
+
+==> To do the above with use-package (and a few optional dependencies):
+
+(use-package spaceline-config
+ :after powerline anzu winum ;And any other optional dependencies
+ :config
+ (setq powerline-default-separator 'utf-8)
+ (spaceline-compile)
+ (spaceline-spacemacs-theme))
+
+==> You could also try the emacs theme instead:
+
+(spaceline-emacs-theme)
+
+==> But I highly, highly recommend the "spaceline-all-the-icons" theme
+ as it looks so much better than what you'll get by default here. That
+ package is also on the AUR for you to try.
+
+==> Seriously, it's beautiful.
+
+==> Go try it.
+
+EOF
+}
+
+post_upgrade () {
+ post_install $1
+}