summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c7de9d312c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = emacs-super-save-git
+ pkgdesc = Save Emacs buffers when they lose focus
+ pkgver = r22.1c8fbd5
+ pkgrel = 1
+ url = https://github.com/bbatsov/super-save
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ provides = emacs-super-save
+ conflicts = emacs-super-save
+ source = git+https://github.com/bbatsov/super-save.git
+ sha256sums = SKIP
+
+pkgname = emacs-super-save-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58f06517f286
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+_gituser="bbatsov"
+_gitrepo="super-save"
+
+pkgname=emacs-super-save-git
+pkgver=r22.1c8fbd5
+pkgrel=1
+pkgdesc="Save Emacs buffers when they lose focus"
+url="https://github.com/${_gituser}/${_gitrepo}"
+arch=('any')
+license=('GPL3')
+depends=('emacs')
+makedepends=('git')
+provides=('emacs-super-save')
+conflicts=('emacs-super-save')
+source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitrepo"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_gitrepo"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "$_gitrepo"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+}