summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f06d606d5f3..e27b71aa72bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = emacs-symbols-mode-git
pkgdesc = GNU Emacs major mode for listing symbols from object files
pkgver = 0.3
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/stefanhusmann/emacs-symbols-mode
arch = any
license = GPL3
makedepends = git
depends = emacs
- provides = emacs-symbols-mode-git%-git
- conflicts = emacs-symbols-mode-git%-git
- source = git+https://github.com/stefanhusmann/emacs-symbols-mode.git
+ provides = emacs-symbols-mode
+ conflicts = emacs-symbols-mode
+ source = git+https://gitlab.com/stefanhusmann/emacs-symbols-mode.git
md5sums = SKIP
pkgname = emacs-symbols-mode-git
diff --git a/PKGBUILD b/PKGBUILD
index a7caee520c4e..6cfee9dae0dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,26 @@
pkgname=emacs-symbols-mode-git
pkgver=0.3
-pkgrel=2
+pkgrel=3
pkgdesc="GNU Emacs major mode for listing symbols from object files"
arch=('any')
url="https://github.com/stefanhusmann/emacs-symbols-mode"
license=('GPL3')
depends=('emacs')
makedepends=('git')
-provides=("$pkgname%-git")
-conflicts=("$pkgname%-git")
-source=("git+https://github.com/stefanhusmann/emacs-symbols-mode.git")
+provides=(${pkgname%-git})
+conflicts=(${pkgname%-git})
+source=("git+https://gitlab.com/stefanhusmann/emacs-symbols-mode.git")
md5sums=('SKIP')
_gitname="emacs-symbols-mode"
build() {
- cd "$srcdir/$_gitname"
+ cd $_gitname
emacs -batch -q -f batch-byte-compile symbols-mode.el
}
package() {
- cd "$srcdir/$_gitname"
+ cd $_gitname
install -Dm644 symbols-mode.el \
$pkgdir/usr/share/emacs/site-lisp/symbols-mode.el
install -Dm644 symbols-mode.elc \