summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8fff18293aa7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = emacs-twittering-mode
+ pkgdesc = An emacs major mode for Twitter
+ pkgver = 3.0.0
+ pkgrel = 1
+ url = http://twmode.sourceforge.net/index.html
+ arch = any
+ license = GPL
+ depends = emacs
+ depends = curl
+ source = http://cznic.dl.sourceforge.net/project/twmode/twittering-mode-3.0.0/twittering-mode-3.0.0.tar.gz
+ md5sums = ab47a6a49f4279be948147a58e95927e
+
+pkgname = emacs-twittering-mode
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93712613593a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+#Maintainer: Daichi Shinozaki <dsdseg@gmail.com>
+pkgname=emacs-twittering-mode
+_pkgname=${pkgname/#emacs-/}
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="An emacs major mode for Twitter"
+arch=(any)
+url="http://twmode.sourceforge.net/index.html"
+license=('GPL')
+depends=('emacs' 'curl')
+install=
+source=("http://cznic.dl.sourceforge.net/project/twmode/$_pkgname-$pkgver/$_pkgname-$pkgver.tar.gz")
+md5sums=('ab47a6a49f4279be948147a58e95927e')
+
+
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ emacs -batch -q -f batch-byte-compile $_pkgname.el
+}
+
+package() {
+ install -d $pkgdir/usr/share/emacs/site-lisp
+ install -m644 $srcdir/$_pkgname-$pkgver/$_pkgname.el{,c} $pkgdir/usr/share/emacs/site-lisp
+}