summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b725f91d3848
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = emacs-use-package-git
+ pkgdesc = A use-package declaration for simplifying your .emacs
+ pkgver = r801.3fb8f39
+ pkgrel = 1
+ url = https://github.com/jwiegley/use-package
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ provides = emacs-use-package
+ conflicts = emacs-use-package
+ source = git+https://github.com/jwiegley/use-package.git
+ md5sums = SKIP
+
+pkgname = emacs-use-package-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..16ecd3c1d933
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+use-package/
+*.tar.xz*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18ee825fd700
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+pkgname=emacs-use-package-git
+pkgver=r801.3fb8f39
+pkgrel=1
+pkgdesc="A use-package declaration for simplifying your .emacs"
+url="https://github.com/jwiegley/use-package"
+arch=('any')
+license=('GPL3')
+depends=('emacs')
+makedepends=('git')
+provides=('emacs-use-package')
+conflicts=('emacs-use-package')
+source=("git+https://github.com/jwiegley/use-package.git")
+md5sums=('SKIP')
+_gitname="use-package"
+
+pkgver() {
+ cd "$_gitname"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_gitname"
+ rm use-package-tests.el
+ emacs -Q -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd $_gitname
+ install -d "${pkgdir}/usr/share/emacs/site-lisp/use-package"
+ install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/use-package/"
+}