summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9de7475e666b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = emacs-wucuo-git
+ pkgdesc = Spell check your code so it reach to the status of WuCuo (no typo)
+ pkgver = r6.8efca1d
+ pkgrel = 1
+ url = https://github.com/redguardtoo/wucuo
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ provides = emacs-wucuo
+ conflicts = emacs-wucuo
+ source = git+https://github.com/redguardtoo/wucuo.git
+ sha256sums = SKIP
+
+pkgname = emacs-wucuo-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d155afed98f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+_gituser="redguardtoo"
+_gitrepo="wucuo"
+
+pkgname=emacs-wucuo-git
+pkgver=r6.8efca1d
+pkgrel=1
+pkgdesc="Spell check your code so it reach to the status of WuCuo (no typo)"
+url="https://github.com/${_gituser}/${_gitrepo}"
+arch=('any')
+license=('GPL3')
+depends=('emacs')
+makedepends=('git')
+provides=('emacs-wucuo')
+conflicts=('emacs-wucuo')
+source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitrepo"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_gitrepo"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "$_gitrepo"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+}