summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD30
2 files changed, 17 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8c19d9f6b49..d4dc56c167f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = emacs-yasnippet-git
pkgdesc = Yet another template system for Emacs - git version
- pkgver = 0.13.0.r38.ga66f15e
+ pkgver = 0.13.0.r41.g3bf9a3b
pkgrel = 1
epoch = 1
url = https://github.com/joaotavora/yasnippet
diff --git a/PKGBUILD b/PKGBUILD
index 6279711ecb72..2d7d851f3bfe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=emacs-yasnippet-git
epoch=1
-pkgver=0.13.0.r38.ga66f15e
+pkgver=0.13.0.r41.g3bf9a3b
pkgrel=1
pkgdesc="Yet another template system for Emacs - git version"
arch=('any')
@@ -19,25 +19,27 @@ sha256sums=('SKIP')
_gitname=yasnippet
pkgver() {
- cd $_gitname
- ( set -o pipefail
- git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ cd $_gitname
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ )
}
build() {
- cd "${_gitname}"
- rake yasnippet.elc
- rake yasnippet-debug.elc
- rake yasnippet-tests.elc #emacs=24.3 tests_Werror=nil
+ cd "${_gitname}"
+ rake yasnippet.elc
+ rake yasnippet-debug.elc
+ rake yasnippet-tests.elc #emacs=24.3 tests_Werror=nil
}
+
check() {
- cd "${_gitname}"
- rake tests
+ cd "${_gitname}"
+ rake tests
}
+
package () {
- cd "${_gitname}"
- install -d "${pkgdir}/usr/share/emacs/site-lisp/${_gitname}"
- cp -r * "${pkgdir}/usr/share/emacs/site-lisp/${_gitname}"
+ cd "${_gitname}"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/${_gitname}
+ cp -r * "$pkgdir"/usr/share/emacs/site-lisp/${_gitname}
}