summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD12
2 files changed, 19 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af2f7ed52d1b..6402b0c4af2c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,27 @@
pkgbase = eman2
pkgdesc = Greyscale scientific image processing suite for processing data from transmission electron microscopes
pkgver = 2.2
- pkgrel = 2
+ pkgrel = 3
url = http://blake.bcm.edu/emanwiki/EMAN2
arch = x86_64
license = GPL
- depends = python2 libjpeg-turbo python2-numpy hdf5 fftw boost libtiff libpng cmake gsl ftgl python2-matplotlib ipython qt4 python2-pyqt4 python2-opengl
+ depends = python2-numpy
+ depends = hdf5
+ depends = fftw
+ depends = boost
+ depends = qtwebkit
+ depends = cmake
+ depends = gsl
+ depends = ftgl
+ depends = python2-matplotlib
+ depends = ipython
+ depends = python2-pyqt4
+ depends = python2-opengl
options = !strip
source = http://ncmi.bcm.edu/ncmi/software/counter_222/software_135/manage_addProduct/NCMI/attendee_factory/eman2.2.linux64.gcc5.tbz
source = eman2.sh
- source = eman2-installer
md5sums = 961c4c16cbb17ddc92e387f4c7ba6556
md5sums = SKIP
- md5sums = SKIP
pkgname = eman2
diff --git a/PKGBUILD b/PKGBUILD
index 4bd5b9505012..b3955286d891 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,24 +6,24 @@
# Maintainer: Joshua Hardy <joshinsilico@gmail.com>
pkgname=eman2
pkgver=2.2
-pkgrel=2
+pkgrel=3
pkgdesc="Greyscale scientific image processing suite for processing data from transmission electron microscopes"
arch=(x86_64)
url="http://blake.bcm.edu/emanwiki/EMAN2"
license=('GPL')
-depends=('python2 libjpeg-turbo python2-numpy hdf5 fftw boost libtiff libpng cmake gsl ftgl python2-matplotlib ipython qt4 python2-pyqt4 python2-opengl')
-source=("http://ncmi.bcm.edu/ncmi/software/counter_222/software_135/manage_addProduct/NCMI/attendee_factory/eman$pkgver.linux64.gcc5.tbz" 'eman2.sh' 'eman2-installer')
-md5sums=('961c4c16cbb17ddc92e387f4c7ba6556' 'SKIP' 'SKIP')
+depends=('python2-numpy' 'hdf5' 'fftw' 'boost' 'qtwebkit' 'cmake' 'gsl' 'ftgl' 'python2-matplotlib' 'ipython' 'python2-pyqt4' 'python2-opengl')
+source=("http://ncmi.bcm.edu/ncmi/software/counter_222/software_135/manage_addProduct/NCMI/attendee_factory/eman$pkgver.linux64.gcc5.tbz" 'eman2.sh')
+md5sums=('961c4c16cbb17ddc92e387f4c7ba6556' 'SKIP')
options=(!strip)
prepare () {
cd "$srcdir/EMAN2"
- rm eman2-installer
- cp ../eman2-installer .
+ sed -i -e s:"EMAN2PYTHON=\$1":"EMAN2PYTHON=/usr/bin/python2":g eman2-installer
}
build() {
cd "$srcdir/EMAN2"
./eman2-installer
+ echo "Restart computer to refresh eman paths and libraries."
}
package() {