summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
-rwxr-xr-xeman2-installer16
3 files changed, 19 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 659b726fb25c..f380cb589d62 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = eman2
pkgdesc = Greyscale scientific image processing suite for processing data from transmission electron microscopes
- pkgver = 2.12
+ pkgver = 2.2
pkgrel = 1
url = http://blake.bcm.edu/emanwiki/EMAN2
arch = x86_64
license = GPL
+ depends = python2 libjpeg-turbo python2-numpy hdf5 fftw boost libtiff libpng cmake gsl ftgl python2-matplotlib ipython qt4 python2-pyqt4 python2-opengl
options = !strip
- source = http://ncmi.bcm.edu/ncmi/software/counter_222/software_133/manage_addProduct/NCMI/attendee_factory/eman2.12.linux64.tar.gz
+ source = http://ncmi.bcm.edu/ncmi/software/counter_222/software_135/manage_addProduct/NCMI/attendee_factory/eman2.2.linux64.gcc5.tbz
source = eman2.sh
source = eman2-installer
- md5sums = 2e21b310c957fc3b21f8c6b551b60fdb
+ md5sums = 961c4c16cbb17ddc92e387f4c7ba6556
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 50f466882ad2..5dc7144272b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,16 +5,15 @@
# Maintainer: Joshua Hardy <joshinsilico@gmail.com>
pkgname=eman2
-pkgver=2.12
+pkgver=2.2
pkgrel=1
pkgdesc="Greyscale scientific image processing suite for processing data from transmission electron microscopes"
arch=(x86_64)
url="http://blake.bcm.edu/emanwiki/EMAN2"
license=('GPL')
-depends=()
-source=("http://ncmi.bcm.edu/ncmi/software/counter_222/software_133/manage_addProduct/NCMI/attendee_factory/eman$pkgver.linux64.tar.gz"
-'eman2.sh' 'eman2-installer')
-md5sums=('2e21b310c957fc3b21f8c6b551b60fdb' 'SKIP' 'SKIP')
+depends=('python2 libjpeg-turbo python2-numpy hdf5 fftw boost libtiff libpng cmake gsl ftgl python2-matplotlib ipython qt4 python2-pyqt4 python2-opengl')
+source=("http://ncmi.bcm.edu/ncmi/software/counter_222/software_135/manage_addProduct/NCMI/attendee_factory/eman$pkgver.linux64.gcc5.tbz" 'eman2.sh' 'eman2-installer')
+md5sums=('961c4c16cbb17ddc92e387f4c7ba6556' 'SKIP' 'SKIP')
options=(!strip)
prepare () {
@@ -24,11 +23,6 @@ prepare () {
}
build() {
cd "$srcdir/EMAN2"
-# sed -e 's,export EMAN2DIR=`pwd`,export EMAN2DIR=/opt/eman2,' $srcdir/EMAN2/eman2-installer >
-#$srcdir/EMAN2/eman2-installer.tmp
-# mv $srcdir/EMAN2/eman2-installer.tmp $srcdir/EMAN2/eman2-installer
-# chmod +x eman2-installer
-# EMAN2DIR=pwd
./eman2-installer
}
diff --git a/eman2-installer b/eman2-installer
index 8254f7181222..b3982b335125 100755
--- a/eman2-installer
+++ b/eman2-installer
@@ -9,7 +9,7 @@
# Date: 9/1/2009, --disable_cache, Grant Tang
# Date: 6/30/2013, Significant updates by Ian Rees for new build system.
# Date: 8/01/2013, changed disable_cache to disable_gui
-
+# Date: 1/23/2017, altered eman2.[bashrc/cshrc] files to include new matplotlibrc file in extlib
usage()
{
echo "usage: `basename $0` [--disable_gui]"
@@ -34,8 +34,11 @@ setup_shell() {
echo "Unkown shell. You will need set up your enviroment variables manually."
fi
if test "X${RCFILE}" != "X"; then
- echo "Please add the following line to the end of your ${HOME}/${RCFILE} :"
- echo "source ${EMAN2DIR}/eman2${RCFILE}"
+ #echo "Please add the following line to the end of your ${HOME}/${RCFILE} :"
+ #echo "source ${EMAN2DIR}/eman2${RCFILE}"
+ #echo ""
+ #echo "If you experience any problems after installation, please see for tips:"
+ #echo "http:/eman2.org/Install/BinaryInstall"
fi
}
@@ -48,6 +51,7 @@ setup_csh() {
echo 'else' >> ${OUT}
echo ' setenv PYTHONPATH ${EMAN2DIR}/lib:${EMAN2DIR}/bin:${PYTHONPATH}' >> ${OUT}
echo 'endif' >> ${OUT}
+ echo 'setenv MATPLOTLIBRC ${EMAN2DIR}/extlib' >> ${OUT}
echo 'alias sparx sx.py' >> ${OUT}
echo "setenv LC_CTYPE=en_US.utf8"
echo "setenv LC_ALL=en_US.utf8"
@@ -59,8 +63,10 @@ setup_bash()
echo "export EMAN2DIR=${EMAN2DIR}" > ${OUT}
echo 'export PATH=${EMAN2DIR}/bin:${EMAN2DIR}/extlib/bin:$PATH' >> ${OUT}
echo 'export PYTHONPATH=${EMAN2DIR}/lib:${EMAN2DIR}/bin:${PYTHONPATH}' >> ${OUT}
+ echo 'export MATPLOTLIBRC=${EMAN2DIR}/extlib' >> ${OUT}
echo 'export LC_CTYPE=en_US.utf8'
echo 'export LC_ALL=en_US.utf8'
+ echo 'alias sphire=sxgui.py' >> ${OUT}
echo 'alias sparx=sx.py' >> ${OUT}
}
@@ -69,9 +75,9 @@ setup_python()
EMAN2PYTHON=$1
# Update python interpreter
find ${EMAN2DIR}/extlib/bin -name "ipython" \
- -exec sed -i "s%^\#\!.*python.*$%\#\!/opt/eman2/extlib/bin/python%" {} \;
+ -exec sed -i "s%^\#\!.*python.*$%\#\!$/opt/eman2/extlib/bin/python%" {} \;
find ${EMAN2DIR}/test ${EMAN2DIR}/bin ${EMAN2DIR}/lib ${EMAN2DIR}/examples -name "*.py" \
- -exec sed -i "s%^\#\!.*python.*$%\#\!/opt/eman2/extlib/bin/python%" {} \;
+ -exec sed -i "s%^\#\!.*python.*$%\#\!$/opt/eman2/extlib/bin/python%" {} \;
find ${EMAN2DIR}/test ${EMAN2DIR}/bin ${EMAN2DIR}/lib ${EMAN2DIR}/examples -name "*.py" \
-exec chmod a+x {} \;
# ... and for SPARX