summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--PluginSecurityManager.cs280
-rw-r--r--PluginSecurityManager.cs.patch64
4 files changed, 8 insertions, 340 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 754c203b27f5..8d7ec0dc8723 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = emby-server-unlocked
pkgdesc = Emby Server compiled with a patch to unlock Emby Premiere features
pkgver = 3.2.26.0
- pkgrel = 2
+ pkgrel = 3
url = http://emby.media
install = emby-server.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 70e18f14d63d..cca0dd9d3a19 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=emby-server-unlocked
pkgver=3.2.26.0
-pkgrel=2
+pkgrel=3
pkgdesc='Emby Server compiled with a patch to unlock Emby Premiere features'
arch=('i686' 'x86_64')
url='http://emby.media'
diff --git a/PluginSecurityManager.cs b/PluginSecurityManager.cs
deleted file mode 100644
index 7b7d42d67c36..000000000000
--- a/PluginSecurityManager.cs
+++ /dev/null
@@ -1,280 +0,0 @@
-using System;
-using System.Collections.Generic;
-using System.IO;
-using System.Linq;
-using System.Net;
-using System.Threading;
-using System.Threading.Tasks;
-using MediaBrowser.Common.Configuration;
-using MediaBrowser.Common.Net;
-using MediaBrowser.Common.Security;
-using MediaBrowser.Controller;
-using MediaBrowser.Model.Cryptography;
-using MediaBrowser.Model.Entities;
-using MediaBrowser.Model.IO;
-using MediaBrowser.Model.Logging;
-using MediaBrowser.Model.Net;
-using MediaBrowser.Model.Serialization;
-
-namespace Emby.Server.Implementations.Security
-{
- /// <summary>
- /// Class PluginSecurityManager
- /// </summary>
- public class PluginSecurityManager : ISecurityManager
- {
- private const string MBValidateUrl = "https://mb3admin.com/admin/service/registration/validate";
- private const string AppstoreRegUrl = /*MbAdmin.HttpsUrl*/ "https://mb3admin.com/admin/service/appstore/register";
-
- /// <summary>
- /// The _is MB supporter
- /// </summary>
- private bool? _isMbSupporter;
- /// <summary>
- /// The _is MB supporter initialized
- /// </summary>
- private bool _isMbSupporterInitialized;
- /// <summary>
- /// The _is MB supporter sync lock
- /// </summary>
- private object _isMbSupporterSyncLock = new object();
-
- /// <summary>
- /// Gets a value indicating whether this instance is MB supporter.
- /// </summary>
- /// <value><c>true</c> if this instance is MB supporter; otherwise, <c>false</c>.</value>
- public bool IsMBSupporter
- {
- get
- {
- LazyInitializer.EnsureInitialized(ref _isMbSupporter, ref _isMbSupporterInitialized, ref _isMbSupporterSyncLock, () => GetSupporterRegistrationStatus().Result.IsRegistered);
- return _isMbSupporter.Value;
- }
- }
-
- private MBLicenseFile _licenseFile;
- private MBLicenseFile LicenseFile
- {
- get { return _licenseFile ?? (_licenseFile = new MBLicenseFile(_appPaths, _fileSystem, _cryptographyProvider)); }
- }
-
- private readonly IHttpClient _httpClient;
- private readonly IJsonSerializer _jsonSerializer;
- private readonly IServerApplicationHost _appHost;
- private readonly ILogger _logger;
- private readonly IApplicationPaths _appPaths;
- private readonly IFileSystem _fileSystem;
- private readonly ICryptoProvider _cryptographyProvider;
-
- private IEnumerable<IRequiresRegistration> _registeredEntities;
- protected IEnumerable<IRequiresRegistration> RegisteredEntities
- {
- get
- {
- return _registeredEntities ?? (_registeredEntities = _appHost.GetExports<IRequiresRegistration>());
- }
- }
-
- /// <summary>
- /// Initializes a new instance of the <see cref="PluginSecurityManager" /> class.
- /// </summary>
- public PluginSecurityManager(IServerApplicationHost appHost, IHttpClient httpClient, IJsonSerializer jsonSerializer,
- IApplicationPaths appPaths, ILogManager logManager, IFileSystem fileSystem, ICryptoProvider cryptographyProvider)
- {
- if (httpClient == null)
- {
- throw new ArgumentNullException("httpClient");
- }
-
- _appHost = appHost;
- _httpClient = httpClient;
- _jsonSerializer = jsonSerializer;
- _appPaths = appPaths;
- _fileSystem = fileSystem;
- _cryptographyProvider = cryptographyProvider;
- _logger = logManager.GetLogger("SecurityManager");
- }
-
- /// <summary>
- /// Load all registration info for all entities that require registration
- /// </summary>
- /// <returns></returns>
- public async Task LoadAllRegistrationInfo()
- {
- var tasks = new List<Task>();
-
- ResetSupporterInfo();
- tasks.AddRange(RegisteredEntities.Select(i => i.LoadRegistrationInfoAsync()));
- await Task.WhenAll(tasks);
- }
-
- /// <summary>
- /// Gets the registration status.
- /// This overload supports existing plug-ins.
- /// </summary>
- /// <param name="feature">The feature.</param>
- /// <param name="mb2Equivalent">The MB2 equivalent.</param>
- /// <returns>Task{MBRegistrationRecord}.</returns>
- public Task<MBRegistrationRecord> GetRegistrationStatus(string feature, string mb2Equivalent = null)
- {
- return GetRegistrationStatusInternal(feature, mb2Equivalent);
- }
-
- /// <summary>
- /// Gets the registration status.
- /// </summary>
- /// <param name="feature">The feature.</param>
- /// <param name="mb2Equivalent">The MB2 equivalent.</param>
- /// <param name="version">The version of this feature</param>
- /// <returns>Task{MBRegistrationRecord}.</returns>
- public Task<MBRegistrationRecord> GetRegistrationStatus(string feature, string mb2Equivalent, string version)
- {
- return GetRegistrationStatusInternal(feature, mb2Equivalent, version);
- }
-
- private Task<MBRegistrationRecord> GetSupporterRegistrationStatus()
- {
- return GetRegistrationStatusInternal("MBSupporter", null, _appHost.ApplicationVersion.ToString());
- }
-
- /// <summary>
- /// Gets or sets the supporter key.
- /// </summary>
- /// <value>The supporter key.</value>
- public string SupporterKey
- {
- get
- {
- return LicenseFile.RegKey;
- }
- set
- {
- var newValue = value;
- if (newValue != null)
- {
- newValue = newValue.Trim();
- }
-
- if (newValue != LicenseFile.RegKey)
- {
- LicenseFile.RegKey = newValue;
- LicenseFile.Save();
-
- // re-load registration info
- Task.Run(() => LoadAllRegistrationInfo());
- }
- }
- }
-
- /// <summary>
- /// Register an app store sale with our back-end. It will validate the transaction with the store
- /// and then register the proper feature and then fill in the supporter key on success.
- /// </summary>
- /// <param name="parameters">Json parameters to send to admin server</param>
- public async Task RegisterAppStoreSale(string parameters)
- {
- var options = new HttpRequestOptions()
- {
- Url = AppstoreRegUrl,
- CancellationToken = CancellationToken.None,
- BufferContent = false
- };
- options.RequestHeaders.Add("X-Emby-Token", _appHost.SystemId);
- options.RequestContent = parameters;
- options.RequestContentType = "application/json";
-
- try
- {
- using (var response = await _httpClient.Post(options).ConfigureAwait(false))
- {
- var reg = _jsonSerializer.DeserializeFromStream<RegRecord>(response.Content);
-
- if (reg == null)
- {
- var msg = "Result from appstore registration was null.";
- _logger.Error(msg);
- throw new ArgumentException(msg);
- }
- if (!String.IsNullOrEmpty(reg.key))
- {
- SupporterKey = reg.key;
- }
- }
-
- }
- catch (ArgumentException)
- {
- SaveAppStoreInfo(parameters);
- throw;
- }
- catch (HttpException e)
- {
- _logger.ErrorException("Error registering appstore purchase {0}", e, parameters ?? "NO PARMS SENT");
-
- if (e.StatusCode.HasValue && e.StatusCode.Value == HttpStatusCode.PaymentRequired)
- {
- throw new PaymentRequiredException();
- }
- throw new Exception("Error registering store sale");
- }
- catch (Exception e)
- {
- _logger.ErrorException("Error registering appstore purchase {0}", e, parameters ?? "NO PARMS SENT");
- SaveAppStoreInfo(parameters);
- //TODO - could create a re-try routine on start-up if this file is there. For now we can handle manually.
- throw new Exception("Error registering store sale");
- }
-
- }
-
- private void SaveAppStoreInfo(string info)
- {
- // Save all transaction information to a file
-
- try
- {
- _fileSystem.WriteAllText(Path.Combine(_appPaths.ProgramDataPath, "apptrans-error.txt"), info);
- }
- catch (IOException)
- {
-
- }
- }
-
- private async Task<MBRegistrationRecord> GetRegistrationStatusInternal(string feature,
- string mb2Equivalent = null,
- string version = null)
- {
- return new MBRegistrationRecord
- {
- IsRegistered = true,
- RegChecked = true,
- TrialVersion = false,
- IsValid = true,
- RegError = false
- };
- }
-
- private bool IsInTrial(DateTime expirationDate, bool regChecked, bool isRegistered)
- {
- //don't set this until we've successfully obtained exp date
- if (!regChecked)
- {
- return false;
- }
-
- var isInTrial = expirationDate > DateTime.UtcNow;
-
- return isInTrial && !isRegistered;
- }
-
- /// <summary>
- /// Resets the supporter info.
- /// </summary>
- private void ResetSupporterInfo()
- {
- _isMbSupporter = null;
- _isMbSupporterInitialized = false;
- }
- }
-}
diff --git a/PluginSecurityManager.cs.patch b/PluginSecurityManager.cs.patch
index 8044cd7bbe09..61b65ed9e7ca 100644
--- a/PluginSecurityManager.cs.patch
+++ b/PluginSecurityManager.cs.patch
@@ -1,57 +1,7 @@
-*** PluginSecurityManager.cs_ 2017-07-23 02:13:15.000000000 -0400
---- PluginSecurityManager.cs 2017-08-05 19:55:29.509988589 -0400
***************
-*** 117,123 ****
- /// <returns>Task{MBRegistrationRecord}.</returns>
- public Task<MBRegistrationRecord> GetRegistrationStatus(string feature, string mb2Equivalent = null)
- {
-! return GetRegistrationStatusInternal(feature, mb2Equivalent);
- }
-
- /// <summary>
---- 117,123 ----
- /// <returns>Task{MBRegistrationRecord}.</returns>
- public Task<MBRegistrationRecord> GetRegistrationStatus(string feature, string mb2Equivalent = null)
- {
-! return GetRegistrationStatusInternal();
- }
-
- /// <summary>
-***************
-*** 129,140 ****
- /// <returns>Task{MBRegistrationRecord}.</returns>
- public Task<MBRegistrationRecord> GetRegistrationStatus(string feature, string mb2Equivalent, string version)
- {
-! return GetRegistrationStatusInternal(feature, mb2Equivalent, version);
- }
-
- private Task<MBRegistrationRecord> GetSupporterRegistrationStatus()
- {
-! return GetRegistrationStatusInternal("MBSupporter", null, _appHost.ApplicationVersion.ToString());
- }
-
- /// <summary>
---- 129,140 ----
- /// <returns>Task{MBRegistrationRecord}.</returns>
- public Task<MBRegistrationRecord> GetRegistrationStatus(string feature, string mb2Equivalent, string version)
- {
-! return GetRegistrationStatusInternal();
- }
-
- private Task<MBRegistrationRecord> GetSupporterRegistrationStatus()
- {
-! return GetRegistrationStatusInternal();
- }
-
- /// <summary>
-***************
-*** 241,334 ****
- }
- }
-
-! private async Task<MBRegistrationRecord> GetRegistrationStatusInternal(string feature,
-! string mb2Equivalent = null,
-! string version = null)
+*** 245,334 ****
+ string mb2Equivalent = null,
+ string version = null)
{
! var regInfo = LicenseFile.GetRegInfo(feature);
! var lastChecked = regInfo == null ? DateTime.MinValue : regInfo.LastChecked;
@@ -140,11 +90,9 @@
}
private bool IsInTrial(DateTime expirationDate, bool regChecked, bool isRegistered)
---- 241,256 ----
- }
- }
-
-! private async Task<MBRegistrationRecord> GetRegistrationStatusInternal()
+--- 245,258 ----
+ string mb2Equivalent = null,
+ string version = null)
{
! return new MBRegistrationRecord
{