summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD20
2 files changed, 14 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28c56fe4ec07..a165fc8c3092 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Tue Jan 3 14:11:15 UTC 2017
pkgbase = emoj
pkgdesc = Find relevant emoji from text on the command-line
- pkgver = 0.4.0
+ pkgver = 4.0.1
pkgrel = 1
url = https://github.com/sindresorhus/emoj
arch = any
@@ -10,9 +8,8 @@ pkgbase = emoj
makedepends = npm
depends = nodejs
depends = xsel
- noextract = emoj-0.4.0.tgz
- source = https://github.com/sindresorhus/emoj/archive/v0.4.0.tar.gz
- sha1sums = 52f2594b4fdf76a664205ac9bd526be95dccf680
+ noextract = emoj-4.0.1.tgz
+ source = https://github.com/sindresorhus/emoj/archive/v4.0.1.tar.gz
+ sha256sums = e16a5097d22b722a9bd0743beb22af9c9716ec4d9ce5a25953cd25c2b57c10d0
pkgname = emoj
-
diff --git a/PKGBUILD b/PKGBUILD
index 1d18aa7f1247..0e088a629c05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
-# Maintainer: Hugo Osvaldo Barrera <hugo@barrera.io>
+# Maintainer: <reg-archlinux AT klein DOT tuxli DOT ch>
+# Contributor: Hugo Osvaldo Barrera <hugo@barrera.io>
+
pkgname=emoj
-pkgver=0.4.0
+pkgver=4.0.1
pkgrel=1
pkgdesc="Find relevant emoji from text on the command-line"
arch=("any")
-url="https://github.com/sindresorhus/emoj"
+url="https://github.com/sindresorhus/${pkgname}"
license=('MIT')
depends=('nodejs' 'xsel')
makedepends=('npm')
-source=(https://github.com/sindresorhus/$pkgname/archive/v$pkgver.tar.gz)
+source=(https://github.com/sindresorhus/${pkgname}/archive/v${pkgver}.tar.gz)
noextract=($pkgname-$pkgver.tgz)
-sha1sums=('52f2594b4fdf76a664205ac9bd526be95dccf680')
+sha256sums=('e16a5097d22b722a9bd0743beb22af9c9716ec4d9ce5a25953cd25c2b57c10d0')
package() {
- cd $srcdir
-
- install -dm 755 "$pkgdir/usr/lib/node_modules/"
- cd "$pkgdir/usr/lib/node_modules/"
- npm install -g --prefix "$pkgdir/usr" $pkgname@$pkgver
+ install -dm 755 "${pkgdir}/usr/lib/node_modules/"
+ cd "${pkgdir}/usr/lib/node_modules/"
+ npm install -g --prefix "${pkgdir}/usr" ${pkgname}@${pkgver}
}