summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 076b1ee6a1e3..5a0ffb94699a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Feb 27 16:08:09 UTC 2018
+# Wed Jun 20 06:00:21 UTC 2018
pkgbase = emulationstation-autoscraper
pkgdesc = An auto-scraper for EmulationStation written in Go using hashes
pkgver = 1.4.5
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/sselph/scraper
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 45a3ea0bf220..7499d34471b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=emulationstation-autoscraper
pkgver=1.4.5
-pkgrel=1
+pkgrel=2
pkgdesc="An auto-scraper for EmulationStation written in Go using hashes"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
url="https://github.com/sselph/scraper"
@@ -15,18 +15,20 @@ sha256sums=('5e7496b7634126f5be81fdd88a20fe108f40d4a8a0089b2d07ae82ea2cea812c')
scraperdir="scraper-${pkgver}"
build() {
- cd "${srcdir}/${scraperdir}"
- echo $arch
+ # echo $arch # for later use on different arches
+ mkdir -p "github.com/sselph"
+ ln -s "${srcdir}/${scraperdir}" "${srcdir}/github.com/sselph/scraper"
+ GOPATH="$(pwd)" && export GOPATH=$(echo ${GOPATH%src})
echo $(go build github.com/sselph/scraper)
}
package() {
- cd "${srcdir}/${scraperdir}"
+ cd "${srcdir}"
strip "scraper"
- install -Dm755 "${srcdir}/${scraperdir}/scraper" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm755 "${srcdir}/scraper" "${pkgdir}/usr/bin/${pkgname}"
install -Dm644 "${srcdir}/${scraperdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
- for LIC in $(find vendor/github.com -name LICENSE); do
+ for LIC in $(find "${srcdir}/${scraperdir}/vendor/github.com" -name LICENSE); do
PKGNAME="$(echo ${LIC} | awk -F "/" '{print $(NF-1)}')"
- install -Dm644 "${srcdir}/${scraperdir}/${LIC}" "${pkgdir}/usr/share/licenses/${pkgname}/license.${PKGNAME}"
+ install -Dm644 "${LIC}" "${pkgdir}/usr/share/licenses/${pkgname}/license.${PKGNAME}"
done
}