summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD40
-rw-r--r--warnings-fix.patch33
4 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1bfb05964986
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = enchant-pure
+ pkgdesc = A wrapper library for pure and generic spell checking for all languages, supporting Aspell and Myspell/Hunspell engines
+ pkgver = 1.6.0
+ pkgrel = 3
+ url = http://www.abisource.com/enchant/
+ arch = any
+ license = LGPL
+ depends = aspell>=0.50.0
+ depends = dbus-glib>=0.62
+ depends = hunspell
+ provides = enchant
+ conflicts = enchant
+ options = !libtool
+ source = http://www.abisource.com/downloads/enchant/1.6.0/enchant-1.6.0.tar.gz
+ source = warnings-fix.patch
+ sha1sums = 321f9cf0abfa1937401676ce60976d8779c39536
+ sha1sums = 8e23f2b350e77c2a2e9accf1ce1b9a18aefb69ff
+
+pkgname = enchant-pure
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f72d5fb6ac3d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+enchant-*.tar.gz
+*.pkg.tar.xz
+*~
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3986eb79c070
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Behnam Momeni <sbmomeni [at the] gmail [dot] com>
+
+pkgname=('enchant-pure')
+
+_pkgname=enchant
+pkgver=1.6.0
+pkgrel=3
+
+pkgdesc="A wrapper library for pure and generic spell checking for all languages, supporting Aspell and Myspell/Hunspell engines"
+url="http://www.abisource.com/enchant/"
+
+arch=('any')
+license=('LGPL')
+
+depends=('aspell>=0.50.0' 'dbus-glib>=0.62' 'hunspell')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+options=('!libtool')
+
+source=("http://www.abisource.com/downloads/${_pkgname}/${pkgver}/${_pkgname}-${pkgver}.tar.gz"
+ "warnings-fix.patch")
+sha1sums=('321f9cf0abfa1937401676ce60976d8779c39536'
+ '8e23f2b350e77c2a2e9accf1ce1b9a18aefb69ff')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ patch -p1 -i ../warnings-fix.patch
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ ./configure --prefix=/usr --disable-static --disable-ispell --disable-hspell --with-myspell-dir=/usr/share/myspell
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
+
diff --git a/warnings-fix.patch b/warnings-fix.patch
new file mode 100644
index 000000000000..d97935a6c429
--- /dev/null
+++ b/warnings-fix.patch
@@ -0,0 +1,33 @@
+diff -aur enchant-1.6.0/src/enchant.c enchant-1.6.0.new/src/enchant.c
+--- enchant-1.6.0/src/enchant.c 2010-04-02 01:23:37.000000000 +0430
++++ enchant-1.6.0.new/src/enchant.c 2013-07-31 23:26:05.244144048 +0430
+@@ -208,7 +208,9 @@
+ GSList *module_dirs = NULL;
+
+ char * module_dir = NULL;
++#ifndef ENCHANT_GLOBAL_MODULE_DIR
+ char * prefix = NULL;
++#endif
+
+ {
+ char* user_module_dir;
+@@ -840,6 +842,7 @@
+ size_t i, j;
+
+ session = ((EnchantDictPrivateData*)dict->enchant_private_data)->session;
++ (void) session; // unused
+
+ for(i = 0; i < n_new_suggs; i++)
+ {
+diff -aur enchant-1.6.0/src/pwl.c enchant-1.6.0.new/src/pwl.c
+--- enchant-1.6.0/src/pwl.c 2010-04-02 01:23:37.000000000 +0430
++++ enchant-1.6.0.new/src/pwl.c 2013-07-31 23:27:14.200816371 +0430
+@@ -282,7 +282,7 @@
+ {
+ char buffer[BUFSIZ];
+ char* line;
+- size_t line_number = 1;
++ unsigned int line_number = 1;
+ FILE *f;
+ struct stat stats;
+