summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore10
-rw-r--r--PKGBUILD10
3 files changed, 21 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7aec754a10d..134ea3e673fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,9 @@
+# Generated by makepkg 6.0.2
+# Thu Nov 16 09:03:19 UTC 2023
pkgbase = engauge
pkgver = 12.1
- pkgrel = 1
+ pkgrel = 2
+ epoch = 1
url = http://markummitchell.github.io/engauge-digitizer/
install = engauge.install
arch = i686
@@ -13,6 +16,7 @@ pkgbase = engauge
makedepends = libpng
makedepends = openjpeg2
makedepends = poppler-qt5
+ options = !makeflags
source = engauge-12.1.tar.gz::https://github.com/markummitchell/engauge-digitizer/archive/v12.1.tar.gz
source = engauge.sh
source = engauge.desktop
@@ -33,4 +37,3 @@ pkgname = engauge
pkgname = engauge-samples
pkgdesc = sample image files for engauge copied into the doc subdirectory
arch = any
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..962eb0dd956d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,10 @@
+~
+engauge-*.tar.gz
+
+pkg/*
+src/*
+
+engauge-*.log
+engauge-*.log.*
+engauge-*.src.tar.gz
+engauge-*.pkg.tar.*
diff --git a/PKGBUILD b/PKGBUILD
index d7c1346359f7..1eded2cfe6b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,8 @@ _pkgbase='engauge-digitizer'
pkgname=('engauge' 'engauge-samples')
pkgbase='engauge'
pkgver=12.1
-pkgrel=1
+pkgrel=2
+epoch=1
url="http://markummitchell.github.io/engauge-digitizer/"
arch=('i686' 'x86_64')
license=('GPL')
@@ -19,13 +20,14 @@ sha256sums=('b553c71ad8b5565a42ae0ba58891d27ac47ca27cc6d7a442c979b56b1fbda282'
'4b36a8aa23c5a95a552d33ce1bd75aa1a0be5fdf9ef06f321a060c753298dd18'
'1b3f2675058693d5653b5aee50fbec1530791de5fcdfbb2f86056a5d748695a4')
install=engauge.install
+options=('!makeflags')
build() {
cd ${_pkgbase}-$pkgver
- export OPENJPEG_INCLUDE=/usr/include/openjpeg-2.3 OPENJPEG_LIB=/usr/lib
- export POPPLER_INCLUDE=/usr/include/poppler/qt5 POPPLER_LIB=/usr/lib
+ export OPENJPEG_INCLUDE=$(pkg-config --variable includedir libopenjp2) OPENJPEG_LIB=/usr/lib
+ export POPPLER_INCLUDE=$(pkg-config --cflags-only-I poppler-qt5 | cut -d ' ' -f 1 | sed 's/^-I//') POPPLER_LIB=/usr/lib
qmake-qt5 engauge.pro "CONFIG+=pdf jpeg2000"
- make -j2
+ make
lrelease engauge.pro
}