summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD23
-rw-r--r--enroot-git.install8
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d491dde2392f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,40 @@
+pkgbase = enroot-git
+ pkgdesc = A simple yet powerful tool to turn traditional container/OS images into unprivileged sandboxes.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/NVIDIA/enroot
+ install = enroot-git.install
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = gcc
+ makedepends = make
+ makedepends = libcap
+ makedepends = libtool
+ depends = bash
+ depends = coreutils
+ depends = curl
+ depends = gawk
+ depends = jq
+ depends = libbsd
+ depends = parallel
+ depends = shadow
+ depends = squashfs-tools
+ depends = grep
+ depends = findutils
+ depends = gzip
+ depends = glibc
+ depends = sed
+ depends = tar
+ depends = util-linux
+ optdepends = pv
+ optdepends = pigz
+ optdepends = ncurses
+ optdepends = libnvidia-container-tools
+ optdepends = squashfuse
+ optdepends = fuse-overlayfs
+ source = git+https://github.com/NVIDIA/enroot.git#tag=v1.0.0
+ sha256sums = SKIP
+
+pkgname = enroot-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..040b1a6adb89
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=enroot-git
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='A simple yet powerful tool to turn traditional container/OS images into unprivileged sandboxes.'
+url='https://github.com/NVIDIA/enroot'
+arch=(x86_64)
+license=(BSD)
+makedepends=(git gcc make libcap libtool)
+depends=(bash coreutils curl gawk jq libbsd parallel shadow squashfs-tools grep findutils gzip glibc sed tar util-linux)
+optdepends=(pv pigz ncurses libnvidia-container-tools squashfuse fuse-overlayfs)
+source=("git+https://github.com/NVIDIA/enroot.git#tag=v${pkgver}")
+sha256sums=(SKIP)
+install="${pkgname}.install"
+
+build() {
+ cd 'enroot'
+ make prefix=/usr
+}
+
+package() {
+ cd 'enroot'
+ make prefix=/usr DESTDIR="$pkgdir/" install
+}
diff --git a/enroot-git.install b/enroot-git.install
new file mode 100644
index 000000000000..e3ec0e3c6e73
--- /dev/null
+++ b/enroot-git.install
@@ -0,0 +1,8 @@
+post_install() {
+ setcap cap_sys_admin+pe "$(command -v enroot-mksquashovlfs)"
+ setcap cap_sys_admin,cap_mknod+pe "$(command -v enroot-aufs2ovlfs)"
+}
+
+post_upgrade() {
+ post_install
+}