summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
-rw-r--r--moduleshome.patch13
3 files changed, 8 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da5904463f52..a52a92cacf98 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = env-modules
pkgdesc = Provides for an easy dynamic modification of a user's environment via modulefile.
- pkgver = 4.3.1
- pkgrel = 2
+ pkgver = 4.4.0
+ pkgrel = 1
url = https://sourceforge.net/projects/modules/
install = env-modules.install
arch = i686
@@ -12,10 +12,8 @@ pkgbase = env-modules
conflicts = env-modules
replaces = env-modules
backup = etc/modules/init/modulerc
- source = https://sourceforge.net/projects/modules/files/Modules/modules-4.3.1/modules-4.3.1.tar.gz
- source = moduleshome.patch
- md5sums = 70b5a0f6bf8771a26435661794e78b12
- md5sums = 3a3b6ba0ac0766be9ba601223baaf107
+ source = https://sourceforge.net/projects/modules/files/Modules/modules-4.4.0/modules-4.4.0.tar.gz
+ md5sums = f9dfb6dff19bd6fe3b67a6c8413f0e0d
pkgname = env-modules
diff --git a/PKGBUILD b/PKGBUILD
index ecbcf0ef8883..72d1199b2f56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: snafu
pkgname=(env-modules)
-pkgver=4.3.1
-pkgrel=2
+pkgver=4.4.0
+pkgrel=1
epoch=
pkgdesc="Provides for an easy dynamic modification of a user's environment via modulefile."
arch=('i686' 'x86_64')
@@ -18,11 +18,10 @@ replaces=(env-modules)
options=()
install=env-modules.install
changelog=
-source=("https://sourceforge.net/projects/modules/files/Modules/modules-$pkgver/modules-$pkgver.tar.gz" moduleshome.patch)
+source=("https://sourceforge.net/projects/modules/files/Modules/modules-$pkgver/modules-$pkgver.tar.gz")
noextract=()
validpgpkeys=()
-md5sums=('70b5a0f6bf8771a26435661794e78b12'
- '3a3b6ba0ac0766be9ba601223baaf107')
+md5sums=('f9dfb6dff19bd6fe3b67a6c8413f0e0d')
# Install locations:
install_prefix=/usr
@@ -32,13 +31,6 @@ moduledir=modules
backup=("${config_path:1}/${moduledir}/init/modulerc")
-
-prepare() {
- cd "modules-$pkgver"
-
- patch -p1 < ../moduleshome.patch
-}
-
build() {
cd "modules-$pkgver"
@@ -84,4 +76,3 @@ package() {
ln -s ./perl.pm ${pkgdir}${config_path}/${moduledir}/init/perl
ln -s ./python.py ${pkgdir}${config_path}/${moduledir}/init/python
}
-
diff --git a/moduleshome.patch b/moduleshome.patch
deleted file mode 100644
index 201e67e1a0dc..000000000000
--- a/moduleshome.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/modulecmd.tcl.in b/modulecmd.tcl.in
-index 843e178..8e77ec7 100644
---- a/modulecmd.tcl.in
-+++ b/modulecmd.tcl.in
-@@ -9174,7 +9174,7 @@ proc cmdModuleAutoinit {} {
- pushMode load
-
- # default MODULESHOME
-- setenv MODULESHOME @prefix@
-+ setenv MODULESHOME [file dirname @initdir@]
-
- # register command location
- setenv MODULES_CMD [getAbsolutePath $::argv0]