summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD42
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc9e4a9fb23b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = env-modules-tcl
+ pkgdesc = Provides for an easy dynamic modification of a user's environment via modulefile (tcl-only-version).
+ pkgver = 1.832
+ pkgrel = 3
+ url = https://sourceforge.net/projects/modules/
+ arch = i686
+ arch = x86_64
+ license = GPLv2
+ checkdepends = dejagnu
+ depends = tcl>=7.4
+ source = https://sourceforge.net/projects/modules/files/Modules-Tcl/modules-tcl-1.832.tar.gz
+ md5sums = 3a40bf6177cc438481672ce028544828
+
+pkgname = env-modules-tcl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..477063c36b8b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=env-modules-tcl
+pkgver=1.832
+pkgrel=3
+epoch=
+pkgdesc="Provides for an easy dynamic modification of a user's environment via modulefile (tcl-only-version)."
+arch=('i686' 'x86_64')
+url="https://sourceforge.net/projects/modules/"
+license=('GPLv2')
+groups=()
+depends=('tcl>=7.4')
+makedepends=()
+checkdepends=('dejagnu')
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://sourceforge.net/projects/modules/files/Modules-Tcl/modules-tcl-$pkgver.tar.gz")
+md5sums=('3a40bf6177cc438481672ce028544828')
+noextract=()
+validpgpkeys=()
+
+build() {
+ cd modules-tcl-$pkgver
+ ./configure --prefix=/usr --disable-set-binpath --disable-set-manpath
+ make
+}
+
+package() {
+ cd "modules-tcl-$pkgver"
+ make DESTDIR="$pkgdir/" install
+
+ _profiled="$pkgdir/etc/profile.d/"
+ mkdir -p "$_profiled"
+ ln -s /usr/init/profile.csh $_profiled/env-modules-tcl.csh
+ ln -s /usr/init/profile.sh $_profiled/env-modules-tcl.sh
+}
+