summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..20cb61ec470b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = envconsul
+ pkgdesc = Launch a subprocess with environment variables using data from @HashiCorp Consul and Vault.
+ pkgver = 0.6.2
+ pkgrel = 1
+ url = https://github.com/hashicorp/envconsul
+ arch = x86_64
+ license = MPL-2.0
+ provides = envconsul
+ source = https://releases.hashicorp.com/envconsul/0.6.2/envconsul_0.6.2_linux_amd64.tgz
+ md5sums = 490ff5f4981a477cf9767a71492c467e
+
+pkgname = envconsul
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c0dedcd889c9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Jonatan Bravo <zephrax@gmail.com>
+pkgname=envconsul
+pkgver=0.6.2
+pkgrel=1
+epoch=
+pkgdesc="Launch a subprocess with environment variables using data from @HashiCorp Consul and Vault."
+arch=("x86_64")
+url="https://github.com/hashicorp/envconsul"
+license=('MPL-2.0')
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=("envconsul")
+source=("https://releases.hashicorp.com/${pkgname}/0.6.2/envconsul_${pkgver}_linux_amd64.tgz")
+md5sums=("490ff5f4981a477cf9767a71492c467e")
+validpgpkeys=()
+
+package() {
+ cd "${srcdir}/"
+ mkdir -p "${pkgdir}/usr/local/bin"
+ install -m755 "${pkgname}" "${pkgdir}/usr/local/bin/${pkgname}"
+ chmod +x ${pkgdir}/usr/local/bin/${pkgname}
+}