summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7f701764d446
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = envycontrol
+ pkgdesc = Easy GPU switching for Nvidia Optimus laptops under Linux
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/geminis3/EnvyControl
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = git
+ depends = python
+ source = git+https://github.com/geminis3/EnvyControl.git#tag=v1.0
+ sha256sums = SKIP
+
+pkgname = envycontrol
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..521ba3d39715
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Victor Bayas <victorsbayas at gmail dot com>
+
+pkgname=envycontrol
+pkgver=1.0
+pkgrel=1
+pkgdesc="Easy GPU switching for Nvidia Optimus laptops under Linux"
+arch=(any)
+url="https://github.com/geminis3/EnvyControl"
+license=(MIT)
+depends=(python)
+makedepends=(python-setuptools git)
+source=("git+https://github.com/geminis3/EnvyControl.git#tag=v$pkgver")
+sha256sums=('SKIP')
+
+package() {
+ cd "${srcdir}/EnvyControl/"
+
+ python setup.py install --root="$pkgdir/" --optimize=1
+
+ # Copy package license to system
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+} \ No newline at end of file