summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--0001-Install-webextension-into-libdir.patch48
-rw-r--r--PKGBUILD25
3 files changed, 14 insertions, 68 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 56648d79287e..be5d7fec24ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = eolie
pkgdesc = Simple web browser for GNOME
- pkgver = 0.9.0
+ pkgver = 0.9.4
pkgrel = 1
url = https://gnumdk.github.io/eolie-web/
arch = x86_64
@@ -9,15 +9,14 @@ pkgbase = eolie
makedepends = gobject-introspection
makedepends = intltool
makedepends = itstool
+ makedepends = meson
depends = gtkspell3
depends = python-beautifulsoup4
depends = python-cairo
depends = python-gobject
depends = webkit2gtk
- source = https://github.com/gnumdk/eolie/releases/download/0.9/eolie-0.9.0.tar.xz
- source = 0001-Install-webextension-into-libdir.patch
- sha256sums = 4ad882ed899cfa88a24851443a879a1bb9f720ad3639e688c05b04ad44cb63d1
- sha256sums = 3d93e35a917b8101da541e73162dcbe51889c1aa3799e058ec207d59fa6976cc
+ source = https://github.com/gnumdk/eolie/releases/download/0.9.4/eolie-0.9.4.tar.xz
+ sha256sums = 0db7d935cd102675b6ec0499b8ef876c9605059c78929b6d1973eb6b1ffe827f
pkgname = eolie
diff --git a/0001-Install-webextension-into-libdir.patch b/0001-Install-webextension-into-libdir.patch
deleted file mode 100644
index 3073443fc4b6..000000000000
--- a/0001-Install-webextension-into-libdir.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From 7bed9e4b7aa7fec8ca16f47f647b8d04674299e9 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Ball=C3=83=C2=B3=20Gy=C3=83=C2=B6rgy?= <ballogyor@gmail.com>
-Date: Fri, 14 Jul 2017 09:41:37 +0200
-Subject: [PATCH] Install webextension into libdir
-
-Only platform-independent data is allowed in datadir.
----
- eolie.in | 3 ++-
- python-webextension/Makefile.am | 2 +-
- 2 files changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/eolie.in b/eolie.in
-index ea0dfea..b2ffedc 100644
---- a/eolie.in
-+++ b/eolie.in
-@@ -19,6 +19,7 @@ from gi.repository import Gio
-
- localedir = '@localedir@'
- pkgdatadir = '@pkgdatadir@'
-+pkglibdir = '@pkglibdir@'
-
- from eolie.application import Application
-
-@@ -45,7 +46,7 @@ if __name__ == "__main__":
- resource = Gio.resource_load(os.path.join(pkgdatadir, 'eolie.gresource'))
- Gio.Resource._register(resource)
-
-- app = Application("@VERSION@", os.path.join(pkgdatadir, 'webkitextension'))
-+ app = Application("@VERSION@", os.path.join(pkglibdir, 'webkitextension'))
- signal.signal(signal.SIGINT, signal.SIG_DFL)
- if 'EOLIE_TRACE' in os.environ:
- graphviz = GraphvizOutput()
-diff --git a/python-webextension/Makefile.am b/python-webextension/Makefile.am
-index 6b4bf4c..c3cb5f3 100644
---- a/python-webextension/Makefile.am
-+++ b/python-webextension/Makefile.am
-@@ -3,7 +3,7 @@
- # Adrian Perez, 2015-08-25 11:58
- #
-
--webkitextensiondir = $(datadir)/eolie/webkitextension
-+webkitextensiondir = $(libdir)/eolie/webkitextension
- webkitextension_DATA = extension.py
-
- extension.py: extension.py.in Makefile
---
-2.13.2
-
diff --git a/PKGBUILD b/PKGBUILD
index 629e5f19b88c..2be687044270 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,28 @@
# Maintainer: Balló György <ballogyor+arch at gmail dot com>
pkgname=eolie
-pkgver=0.9.0
+pkgver=0.9.4
pkgrel=1
pkgdesc="Simple web browser for GNOME"
arch=('x86_64' 'i686')
url="https://gnumdk.github.io/eolie-web/"
license=('GPL3')
depends=('gtkspell3' 'python-beautifulsoup4' 'python-cairo' 'python-gobject' 'webkit2gtk')
-makedepends=('gobject-introspection' 'intltool' 'itstool')
-source=("https://github.com/gnumdk/$pkgname/releases/download/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
- "0001-Install-webextension-into-libdir.patch")
-sha256sums=('4ad882ed899cfa88a24851443a879a1bb9f720ad3639e688c05b04ad44cb63d1'
- '3d93e35a917b8101da541e73162dcbe51889c1aa3799e058ec207d59fa6976cc')
+makedepends=('gobject-introspection' 'intltool' 'itstool' 'meson')
+source=("https://github.com/gnumdk/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.xz")
+sha256sums=('0db7d935cd102675b6ec0499b8ef876c9605059c78929b6d1973eb6b1ffe827f')
prepare() {
- cd $pkgname-$pkgver
- patch -Np1 -i ../0001-Install-webextension-into-libdir.patch
- autoreconf -fi
+ mkdir build
}
build() {
- cd $pkgname-$pkgver
- ./configure --prefix=/usr --libexecdir=/usr/lib/$pkgname
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
- make
+ cd build
+ meson --prefix=/usr --libexecdir=/usr/lib/$pkgname --buildtype=release ../$pkgname-$pkgver
+ ninja
}
package() {
- cd $pkgname-$pkgver
- make DESTDIR="$pkgdir" install
+ cd build
+ DESTDIR="$pkgdir" ninja install
}