summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD28
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..58402a13a62a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = epiphany-unstable
+ pkgdesc = A GNOME web browser based on the WebKit rendering engine (unstable version)
+ pkgver = 3.21.90
+ pkgrel = 1
+ url = https://wiki.gnome.org/Apps/Web
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = intltool
+ makedepends = itstool
+ makedepends = docbook-xml
+ makedepends = startup-notification
+ makedepends = gobject-introspection
+ depends = libsoup
+ depends = libnotify
+ depends = gsettings-desktop-schemas
+ depends = webkit2gtk-unstable>=2.13.1
+ depends = nss
+ depends = iso-codes
+ depends = dconf
+ depends = gcr
+ depends = gnome-desktop
+ depends = libwnck3
+ depends = gnome-themes-standard
+ provides = epiphany
+ conflicts = epiphany
+ source = http://ftp.gnome.org/pub/GNOME/sources/epiphany/3.21/epiphany-3.21.90.tar.xz
+ md5sums = 1a487a215db94f5f9f055e9fdc972519
+
+pkgname = epiphany-unstable
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..445d4d89d315
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: 100best <jm.100best@hotmail.com>
+
+pkgname=epiphany-unstable
+pkgver=3.21.90
+pkgrel=1
+pkgdesc="A GNOME web browser based on the WebKit rendering engine (unstable version)"
+arch=('i686' 'x86_64')
+url="https://wiki.gnome.org/Apps/Web"
+license=('GPL')
+depends=(libsoup libnotify gsettings-desktop-schemas 'webkit2gtk-unstable>=2.13.1' nss iso-codes
+ dconf gcr gnome-desktop libwnck3 gnome-themes-standard)
+makedepends=(intltool itstool docbook-xml startup-notification
+ gobject-introspection)
+source=(http://ftp.gnome.org/pub/GNOME/sources/epiphany/${pkgver:0:4}/epiphany-$pkgver.tar.xz)
+md5sums=('1a487a215db94f5f9f055e9fdc972519')
+provides=('epiphany')
+conflicts=('epiphany')
+
+build() {
+ "$srcdir/epiphany-$pkgver/configure" --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var --libexecdir=/usr/lib/$pkgname
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make DESTDIR="$pkgdir" install
+}