summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD18
2 files changed, 14 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91b655be2a43..2562ee3bc00f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = epiphany-unstable
- pkgdesc = A GNOME web browser based on the WebKit rendering engine.
- pkgver = 3.35.92
+ pkgdesc = A GNOME web browser based on the WebKit rendering engine
+ pkgver = 3.37.2
pkgrel = 1
url = https://wiki.gnome.org/Apps/Web
arch = x86_64
@@ -19,10 +19,11 @@ pkgbase = epiphany-unstable
depends = gcr
depends = icu
depends = libdazzle
+ depends = libhandy
provides = epiphany
conflicts = epiphany
conflicts = epiphany-git
- source = git+https://gitlab.gnome.org/GNOME/epiphany.git#commit=1cae16e236c0c933d843382c2bf39b3bceade267
+ source = git+https://gitlab.gnome.org/GNOME/epiphany.git#commit=550764aeb06b51fdd0ecb374f61aa3f06078026a
sha256sums = SKIP
pkgname = epiphany-unstable
diff --git a/PKGBUILD b/PKGBUILD
index cc95654f09f3..097932886a89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,22 +4,23 @@
_pkgname=epiphany
pkgname=epiphany-unstable
-pkgver=3.35.92
+pkgver=3.37.2
pkgrel=1
-pkgdesc="A GNOME web browser based on the WebKit rendering engine."
+pkgdesc="A GNOME web browser based on the WebKit rendering engine"
url="https://wiki.gnome.org/Apps/Web"
arch=(x86_64)
license=(GPL)
-depends=(webkit2gtk gcr icu libdazzle)
+depends=(webkit2gtk gcr icu libdazzle libhandy)
makedepends=(docbook-xml startup-notification lsb-release gobject-introspection yelp-tools
appstream-glib git meson)
checkdepends=(xorg-server-xvfb)
groups=(gnome)
-_commit=1cae16e236c0c933d843382c2bf39b3bceade267 # tags/3.35.92^0
+_commit=550764aeb06b51fdd0ecb374f61aa3f06078026a # tags/3.37.2^0
source=("git+https://gitlab.gnome.org/GNOME/epiphany.git#commit=$_commit")
sha256sums=('SKIP')
conflicts=(epiphany epiphany-git)
provides=(epiphany)
+
pkgver() {
cd $_pkgname
git describe --tags | sed 's/-/+/g'
@@ -30,14 +31,15 @@ prepare() {
}
build() {
- arch-meson $_pkgname build \
- -D distributor_name="Arch Linux®"
- ninja -C build
+ arch-meson $_pkgname build
+ meson compile -C build
}
check() {
# ERROR:../epiphany/tests/ephy-web-app-utils-test.c:109:test_web_app_lifetime: assertion failed (g_list_length (apps) == 1): (0 == 1)
- xvfb-run meson test -C build || :
+ dbus-run-session xvfb-run \
+ -s '-screen 0 1920x1080x24 -nolisten local' \
+ meson test -C build --print-errorlogs || :
}
package() {