summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 12 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc802548bc53..11013e550dbe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Wed Feb 15 02:56:13 UTC 2017
pkgbase = epix
pkgdesc = ePiX - Utilities for creating mathematically accurate figures
- pkgver = 1.2.16
+ pkgver = 1.2.22
pkgrel = 1
url = http://mathcs.holycross.edu/~ahwang/epix/ePiX.html
arch = i686
@@ -12,10 +10,9 @@ pkgbase = epix
depends = texlive-latexextra
depends = texlive-pictures
depends = texlive-pstricks
- source = http://mathcs.holycross.edu/~ahwang/epix/epix-1.2.16.tar.gz
- md5sums = 08b37229f99d35e1e74ceb71cba48909
- sha1sums = 83789be6c1fd746715c3daf7d66d49bb81f0b373
- sha256sums = 641ad4cd04c9f9a18477b303ebb06c418fdb96c04fc81b3f06e6cb0ad81953ec
+ source = http://mathcs.holycross.edu/~ahwang/epix/epix-1.2.22.tar.gz
+ md5sums = a002184deb45b5f8bb212db9ee2d712a
+ sha1sums = 32920cb9a612c668b0c8b2e6e1b93ad7f3475de9
+ sha256sums = c314b47110cd3ff081e80f60ac4834c0291da94ddfac805ea20036871f4d488f
pkgname = epix
-
diff --git a/PKGBUILD b/PKGBUILD
index c9f52bd8d59c..a3bf188d6350 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,17 @@
-# Maintainer: aksr <aksr at t-com dot me>
+# Maintainer: Trevor Tilby <trevor dot tilby at gmail dot com>
+# Contributor: aksr <aksr at t-com dot me>
pkgname=epix
-pkgver=1.2.16
+pkgver=1.2.22
pkgrel=1
-epoch=
pkgdesc="ePiX - Utilities for creating mathematically accurate figures"
arch=('i686' 'x86_64')
url="http://mathcs.holycross.edu/~ahwang/epix/ePiX.html"
license=('GPL')
-groups=()
depends=('ghostscript' 'texlive-latexextra' 'texlive-pictures' 'texlive-pstricks')
-makedepends=()
-checkdepends=()
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
source=("http://mathcs.holycross.edu/~ahwang/$pkgname/$pkgname-$pkgver.tar.gz")
-noextract=()
-md5sums=('08b37229f99d35e1e74ceb71cba48909')
-sha1sums=('83789be6c1fd746715c3daf7d66d49bb81f0b373')
-sha256sums=('641ad4cd04c9f9a18477b303ebb06c418fdb96c04fc81b3f06e6cb0ad81953ec')
+md5sums=('a002184deb45b5f8bb212db9ee2d712a')
+sha1sums=('32920cb9a612c668b0c8b2e6e1b93ad7f3475de9')
+sha256sums=('c314b47110cd3ff081e80f60ac4834c0291da94ddfac805ea20036871f4d488f')
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -39,5 +27,6 @@ check() {
package() {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
+ install -D -m644 COPYING $pkgdir/usr/share/licenses/$pkgname/LICENSE
}