summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD36
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..02bb12b8743e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = eprosima-fast-dds
+ pkgdesc = eProsima's Fast-DDS implementation
+ pkgver = 2.0.1
+ pkgrel = 1
+ url = https://github.com/eProsima/Fast-DDS
+ arch = x86_64
+ license = Apache
+ makedepends = cmake
+ depends = asio
+ depends = tinyxml2
+ depends = foonathan_memory-shared
+ source = https://github.com/eProsima/Fast-DDS/archive/v2.0.1.tar.gz
+ sha256sums = d557425232da27c84b6142b17cdbccd3076233b445762a5f232205ecf5fff6ab
+
+pkgname = eprosima-fast-dds
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..efc3f12bb500
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Dennis van der Schagt <dennisschagt@gmail.com>
+pkgname=eprosima-fast-dds
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="eProsima's Fast-DDS implementation"
+arch=('x86_64')
+url="https://github.com/eProsima/Fast-DDS"
+license=('Apache')
+depends=('asio' 'tinyxml2' 'foonathan_memory-shared')
+makedepends=('cmake')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/eProsima/Fast-DDS/archive/v${pkgver}.tar.gz")
+noextract=()
+sha256sums=('d557425232da27c84b6142b17cdbccd3076233b445762a5f232205ecf5fff6ab')
+validpgpkeys=()
+
+build() {
+ cd "Fast-DDS-$pkgver"
+ cmake -B build \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ .
+ make -C build
+}
+
+package() {
+ cd "Fast-DDS-$pkgver"
+ make -C build DESTDIR="$pkgdir/" install
+}