summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--Makefile107
-rw-r--r--PKGBUILD26
-rw-r--r--gcc43.patch20
4 files changed, 134 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b1b012b9d99..246385395092 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,20 @@
+# Generated by mksrcinfo v8
+# Tue Sep 4 21:30:30 UTC 2018
pkgbase = epstool
pkgdesc = Utility to create or extract preview images in EPS files, fix bounding boxes and convert to bitmaps
- pkgver = 3.08
- pkgrel = 4
+ pkgver = 3.09
+ pkgrel = 1
url = http://pages.cs.wisc.edu/~ghost/gsview/epstool.htm
arch = i686
arch = x86_64
license = GPL
- source = http://ftp.de.debian.org/debian/pool/main/e/epstool/epstool_3.08+repack.orig.tar.gz
- source = gcc43.patch
- md5sums = 465a57a598dbef411f4ecbfbd7d4c8d7
- md5sums = 7fdf8e6ecd866c8804a7ca4359a16459
+ makedepends = dos2unix
+ depends = glibc
+ noextract = epstool-3.09.tar.gz
+ source = http://www.ghostgum.com.au/download/epstool-3.09.zip
+ source = Makefile
+ sha256sums = f56f2987b1a0cc759fd6ea80fd49f85c1d4d1cc3b8c60798f8ddd9b42aa3c080
+ sha256sums = 69fe66e25a35adce7861a415e6f14442745438da0850e15bc907cac9a3340001
pkgname = epstool
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..83e6b93be257
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,107 @@
+# Copyright (C) 2002-2005 Ghostgum Software Pty Ltd. All rights reserved.
+#
+# This software is provided AS-IS with no warranty, either express or
+# implied.
+#
+# This software is distributed under licence and may not be copied,
+# modified or distributed except as expressly authorised under the terms
+# of the licence contained in the file LICENCE in this distribution.
+#
+# For more information about licensing, please refer to
+# http://www.ghostgum.com.au/ or contact Ghostsgum Software Pty Ltd,
+# 218 Gallaghers Rd, Glen Waverley VIC 3150, AUSTRALIA,
+# Fax +61 3 9886 6616.
+#
+
+# $Id: epstool.mak,v 1.9 2005/03/25 03:37:59 ghostgum Exp $
+# Make epstool for GNU/Linux
+
+BINDIR=./bin
+OBJDIR=./epsobj
+SRCDIR=./src
+SRCWINDIR=./srcwin
+
+XINCLUDE=
+PFLAGS=
+PLINK=
+
+GTKCFLAGS=
+GTKLIBS=
+
+LIBPNGINC=
+LIBPNGCFLAGS=
+LIBPNGLIBS=
+
+LONGFILEDEF=
+LONGFILEMOD=cfile
+
+include $(SRCDIR)/unixcom.mak
+
+EPSOBJPLAT=$(OD)xnodll$(OBJ) $(OD)$(LONGFILEMOD)$(OBJ)
+EPSLIB=$(LIBPNGLIBS)
+
+BEGIN=$(OD)lib.rsp
+TARGET=epstool
+
+include $(SRCDIR)/common.mak
+
+EPSTOOL_ROOT=/usr
+EPSTOOL_BASE=$(prefix)$(EPSTOOL_ROOT)
+EPSTOOL_DOCDIR=$(EPSTOOL_BASE)/share/doc/epstool-$(EPSTOOL_VERSION)
+EPSTOOL_MANDIR=$(EPSTOOL_BASE)/share/man
+EPSTOOL_BINDIR=$(EPSTOOL_BASE)/bin
+
+epstool: $(BD)epstool$(EXE)
+
+epstest: epstool $(BD)epstest$(EXE)
+ $(BD)epstest$(EXE)
+
+$(OD)lib.rsp: makefile
+ -mkdir $(BINDIR)
+ -mkdir $(OBJDIR)
+ echo "dummy" > $(OD)lib.rsp
+
+install: $(TARGET)
+ -mkdir -p $(EPSTOOL_BASE)
+ chmod a+rx $(EPSTOOL_BASE)
+ -mkdir -p $(EPSTOOL_BINDIR)
+ chmod a+rx $(EPSTOOL_BINDIR)
+ $(INSTALL_EXE) $(BD)epstool$(EXE) $(EPSTOOL_BINDIR)$(DD)epstool$(EXE)
+ -strip $(EPSTOOL_BINDIR)$(DD)epstool$(EXE)
+ -mkdir -p $(EPSTOOL_MANDIR)
+ chmod a+rx $(EPSTOOL_MANDIR)
+ -mkdir -p $(EPSTOOL_MANDIR)$(DD)man1
+ chmod a+rx $(EPSTOOL_MANDIR)$(DD)man1
+ $(INSTALL) doc$(DD)epstool.1 $(EPSTOOL_MANDIR)$(DD)man1$(DD)epstool.1
+ -mkdir -p $(EPSTOOL_DOCDIR)
+ chmod a+rx $(EPSTOOL_DOCDIR)
+ $(INSTALL) doc$(DD)epstool.htm $(EPSTOOL_DOCDIR)$(DD)epstool.htm
+ $(INSTALL) doc$(DD)gsview.css $(EPSTOOL_DOCDIR)$(DD)gsview.css
+ $(INSTALL) LICENCE $(EPSTOOL_DOCDIR)$(DD)LICENCE
+
+
+CYGWIN_DISTDIR=./dist
+CYGWIN_PACKAGE=epstool-$(EPSTOOL_VERSION)-1
+CYGWIN_DOCDIR=$(CYGWIN_DISTDIR)/usr/share/doc/Cygwin
+cygwin:
+ rm -rf $(CYGWIN_DISTDIR)/*
+ $(MAKE) -f src/epstool.mak prefix=$(CYGWIN_DISTDIR) EXE=.exe EPSTOOL_ROOT=/usr EPSTOOL_MANDIR=$(CYGWIN_DISTDIR)/usr/share/man install
+ -mkdir -p $(CYGWIN_DOCDIR)
+ chmod a+rx $(CYGWIN_DOCDIR)
+ $(INSTALL) doc/cygwin.README $(CYGWIN_DOCDIR)$(DD)epstool-$(EPSTOOL_VERSION).README
+ (cd $(CYGWIN_DISTDIR); tar -cjf ../$(CYGWIN_PACKAGE).tar.bz2 *)
+ rm -rf $(CYGWIN_DISTDIR)/*
+ mv $(CYGWIN_PACKAGE).tar.bz2 $(CYGWIN_DISTDIR)
+ cp doc/cygwin.hint $(CYGWIN_DISTDIR)/setup.hint
+ make -f src/epstool.mak EXE=.exe EPSDIST=$(CYGWIN_PACKAGE) $(EPSTAR)
+ mv $(EPSTAR) $(CYGWIN_DISTDIR)/$(CYGWIN_PACKAGE)-src.tar
+ bzip2 $(CYGWIN_DISTDIR)/$(CYGWIN_PACKAGE)-src.tar
+
+clean:
+ -$(RM) $(EPSOBJS)
+ -$(RM) $(EPSTESTOBJS)
+ -$(RM) $(OD)lib.rsp
+ -$(RM) $(BD)epstool$(EXE)
+ -$(RM) $(BD)epstest$(EXE)
+ -rmdir $(OBJDIR)
+
diff --git a/PKGBUILD b/PKGBUILD
index 464eb6b98b76..53606e7bbadd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,28 +3,34 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=epstool
-pkgver=3.08
-pkgrel=4
+pkgver=3.09
+pkgrel=1
pkgdesc="Utility to create or extract preview images in EPS files, fix bounding boxes and convert to bitmaps"
arch=('i686' 'x86_64')
url="http://pages.cs.wisc.edu/~ghost/gsview/epstool.htm"
license=('GPL')
-source=("http://ftp.de.debian.org/debian/pool/main/e/epstool/${pkgname}_${pkgver}+repack.orig.tar.gz" "gcc43.patch")
-md5sums=('465a57a598dbef411f4ecbfbd7d4c8d7'
- '7fdf8e6ecd866c8804a7ca4359a16459')
+source=("http://www.ghostgum.com.au/download/$pkgname-$pkgver.zip" Makefile)
+sha256sums=('f56f2987b1a0cc759fd6ea80fd49f85c1d4d1cc3b8c60798f8ddd9b42aa3c080'
+ '69fe66e25a35adce7861a415e6f14442745438da0850e15bc907cac9a3340001')
+depends=('glibc')
+makedepends=('dos2unix')
+noextract=("$pkgname-$pkgver.tar.gz")
prepare() {
- cd "$srcdir/$pkgname-$pkgver"
- patch -p1 -i ../gcc43.patch
+ find "$srcdir"/$pkgname-$pkgver $pkg -type f -exec dos2unix {} \;
+ find "$srcdir"/$pkgname-$pkgver -type f -name "*.exe" -exec rm {} \;
+ cd $pkgname-$pkgver
+
+ cp "$srcdir"/Makefile makefile
}
build() {
- cd "$srcdir/$pkgname-$pkgver"
- make
+ cd $pkgname-$pkgver
+ make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd $pkgname-$pkgver
make prefix="${pkgdir}" EPSTOOL_ROOT=/usr install
}
diff --git a/gcc43.patch b/gcc43.patch
deleted file mode 100644
index 398ce08c5182..000000000000
--- a/gcc43.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- epstool-3.08.orig/src/epstool.c 2005-06-10 04:41:00.000000000 -0500
-+++ epstool-3.08/src/epstool.c 2009-02-16 20:55:43.186140029 -0600
-@@ -2824,7 +2824,7 @@
- code = -1;
- }
- if ((code==0) && stdout_name && (hChildStdoutWr == -1)) {
-- handle = open(stdout_name, O_WRONLY | O_CREAT);
-+ handle = open(stdout_name, O_WRONLY | O_CREAT, 0644);
- hChildStdoutWr = dup2(handle, 1);
- if (handle != -1)
- close(handle);
-@@ -2832,7 +2832,7 @@
- code = -1;
- }
- if ((code==0) && stderr_name && (hChildStderrWr == -1)) {
-- handle = open(stderr_name, O_WRONLY | O_CREAT);
-+ handle = open(stderr_name, O_WRONLY | O_CREAT, 0644);
- hChildStderrWr = dup2(handle, 2);
- if (handle != -1)
- close(handle);