summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
-rw-r--r--gcc43.patch20
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8b1b012b9d99
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = epstool
+ pkgdesc = Utility to create or extract preview images in EPS files, fix bounding boxes and convert to bitmaps
+ pkgver = 3.08
+ pkgrel = 4
+ url = http://pages.cs.wisc.edu/~ghost/gsview/epstool.htm
+ arch = i686
+ arch = x86_64
+ license = GPL
+ source = http://ftp.de.debian.org/debian/pool/main/e/epstool/epstool_3.08+repack.orig.tar.gz
+ source = gcc43.patch
+ md5sums = 465a57a598dbef411f4ecbfbd7d4c8d7
+ md5sums = 7fdf8e6ecd866c8804a7ca4359a16459
+
+pkgname = epstool
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..464eb6b98b76
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Orivej Desh <orivej@gmx.fr>
+# Contributor: Benjamin van der Burgh <benjaminvdb@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=epstool
+pkgver=3.08
+pkgrel=4
+pkgdesc="Utility to create or extract preview images in EPS files, fix bounding boxes and convert to bitmaps"
+arch=('i686' 'x86_64')
+url="http://pages.cs.wisc.edu/~ghost/gsview/epstool.htm"
+license=('GPL')
+source=("http://ftp.de.debian.org/debian/pool/main/e/epstool/${pkgname}_${pkgver}+repack.orig.tar.gz" "gcc43.patch")
+md5sums=('465a57a598dbef411f4ecbfbd7d4c8d7'
+ '7fdf8e6ecd866c8804a7ca4359a16459')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -p1 -i ../gcc43.patch
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make prefix="${pkgdir}" EPSTOOL_ROOT=/usr install
+}
+
diff --git a/gcc43.patch b/gcc43.patch
new file mode 100644
index 000000000000..398ce08c5182
--- /dev/null
+++ b/gcc43.patch
@@ -0,0 +1,20 @@
+--- epstool-3.08.orig/src/epstool.c 2005-06-10 04:41:00.000000000 -0500
++++ epstool-3.08/src/epstool.c 2009-02-16 20:55:43.186140029 -0600
+@@ -2824,7 +2824,7 @@
+ code = -1;
+ }
+ if ((code==0) && stdout_name && (hChildStdoutWr == -1)) {
+- handle = open(stdout_name, O_WRONLY | O_CREAT);
++ handle = open(stdout_name, O_WRONLY | O_CREAT, 0644);
+ hChildStdoutWr = dup2(handle, 1);
+ if (handle != -1)
+ close(handle);
+@@ -2832,7 +2832,7 @@
+ code = -1;
+ }
+ if ((code==0) && stderr_name && (hChildStderrWr == -1)) {
+- handle = open(stderr_name, O_WRONLY | O_CREAT);
++ handle = open(stderr_name, O_WRONLY | O_CREAT, 0644);
+ hChildStderrWr = dup2(handle, 2);
+ if (handle != -1)
+ close(handle);