summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
-rw-r--r--eruption.install7
3 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d22c790ae651..4d526480d1dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = eruption-roccat-vulcan-git
pkgdesc = Linux user-mode driver for the ROCCAT Vulcan 100/12x series keyboards
pkgver = 0.0.9
- pkgrel = 3
+ pkgrel = 4
url = https://x3n0m0rph59.gitlab.io/eruption-roccat-vulcan/
install = eruption.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 9eb2ed74893e..fd86c6c53be7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname='eruption-roccat-vulcan-git'
_pkgname='eruption-roccat-vulcan'
pkgdesc='Linux user-mode driver for the ROCCAT Vulcan 100/12x series keyboards'
pkgver='0.0.9'
-pkgrel='3'
+pkgrel='4'
epoch=
arch=('i686' 'x86_64')
url='https://x3n0m0rph59.gitlab.io/eruption-roccat-vulcan/'
@@ -90,10 +90,10 @@ package() {
install -m 644 "src/scripts/temperature.lua" "$pkgdir/usr/lib/eruption/scripts/"
install -m 644 "src/scripts/temperature.lua.manifest" "$pkgdir/usr/lib/eruption/scripts/"
- install -m 644 "support/templates/about.html.tera" "$pkgdir/usr/share/eruption/templates/"
- install -m 644 "support/templates/base.html.tera" "$pkgdir/usr/share/eruption/templates/"
- install -m 644 "support/templates/detail.html.tera" "$pkgdir/usr/share/eruption/templates/"
- install -m 644 "support/templates/documentation.html.tera" "$pkgdir/usr/share/eruption/templates/"
- install -m 644 "support/templates/profiles.html.tera" "$pkgdir/usr/share/eruption/templates/"
- install -m 644 "support/templates/settings.html.tera" "$pkgdir/usr/share/eruption/templates/"
+ install -m 644 "templates/about.html.tera" "$pkgdir/usr/share/eruption/templates/"
+ install -m 644 "templates/base.html.tera" "$pkgdir/usr/share/eruption/templates/"
+ install -m 644 "templates/detail.html.tera" "$pkgdir/usr/share/eruption/templates/"
+ install -m 644 "templates/documentation.html.tera" "$pkgdir/usr/share/eruption/templates/"
+ install -m 644 "templates/profiles.html.tera" "$pkgdir/usr/share/eruption/templates/"
+ install -m 644 "templates/settings.html.tera" "$pkgdir/usr/share/eruption/templates/"
}
diff --git a/eruption.install b/eruption.install
index cc834db0e54d..633be9965b88 100644
--- a/eruption.install
+++ b/eruption.install
@@ -1,13 +1,14 @@
-post_install() {
+post_install() {
systemctl preset eruption
systemctl reload dbus.service
udevadm control --reload-rules
+ udevadm trigger -s usb
}
pre_remove() {
- systemctl stop eruption.service
+ systemctl stop eruption.service
}
post_remove() {
- systemctl daemon-reload
+ systemctl daemon-reload
}