summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD37
-rw-r--r--erwiz.changelog22
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6db8c996704b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sat Mar 5 16:49:49 UTC 2016
+pkgbase = erwiz
+ pkgdesc = A lightweight tool to convert text-based entity-relationship models to images.
+ pkgver = 0.9.0
+ pkgrel = 3
+ url = http://erwiz.org
+ changelog = erwiz.changelog
+ arch = i686
+ arch = x86_64
+ license = custom:BSD
+ depends = java-runtime
+ depends = graphviz
+ source = http://erwiz.de/download/erwiz-0.9.0-bin.tar.gz
+ md5sums = cf25f05c8462e5f80e7b16f15c76ff4e
+
+pkgname = erwiz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d277612649ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Romain Schmitz <slopjong [[at]] hackerspace [[dot]] lu>
+pkgname=erwiz
+pkgver=(0.9.0)
+pkgrel=3
+pkgdesc="A lightweight tool to convert text-based entity-relationship models to images."
+arch=('i686' 'x86_64')
+url="http://erwiz.org"
+license=('custom:BSD')
+depends=('java-runtime' 'graphviz')
+changelog=${pkgname}.changelog
+source=(http://erwiz.de/download/${pkgname}-${pkgver}-bin.tar.gz)
+#source=(${pkgname}-${pkgver}-bin.tar.gz)
+md5sums=(cf25f05c8462e5f80e7b16f15c76ff4e)
+
+package() {
+
+ # prepare the fake filesystem
+ mkdir -p ${pkgdir}/usr/share/java/${pkgname}
+ mkdir -p ${pkgdir}/usr/share/doc/${pkgname}
+ mkdir -p ${pkgdir}/usr/bin
+
+ # install the binaries and symlink erwiz in /usr/bin
+ cp -R ${srcdir}/${pkgname}-${pkgver}-bin/bin ${pkgdir}/usr/share/java/${pkgname}
+ cp -R ${srcdir}/${pkgname}-${pkgver}-bin/jar ${pkgdir}/usr/share/java/${pkgname}
+ ln -s /usr/share/java/${pkgname}/bin/${pkgname} ${pkgdir}/usr/bin/${pkgname}
+
+ # install the documentation and examples
+ cp -R ${srcdir}/${pkgname}-${pkgver}-bin/doc/htmldoc "${pkgdir}/usr/share/doc/${pkgname}/htmldoc"
+ cp -R ${srcdir}/${pkgname}-${pkgver}-bin/doc/examples "${pkgdir}/usr/share/doc/${pkgname}/examples"
+ install -D -m644 ${srcdir}/${pkgname}-${pkgver}-bin/readme.txt "${pkgdir}/usr/share/doc/${pkgname}/README"
+
+ # install the license stuff
+ install -D -m644 ${srcdir}/${pkgname}-${pkgver}-bin/license.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 ${srcdir}/${pkgname}-${pkgver}-bin/authors.txt "${pkgdir}/usr/share/licenses/${pkgname}/AUTHORS"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/erwiz.changelog b/erwiz.changelog
new file mode 100644
index 000000000000..813c60ce8f60
--- /dev/null
+++ b/erwiz.changelog
@@ -0,0 +1,22 @@
+2011-09-01 Romain Schmitz <slopjong@hackerspace.lu>
+
+ * 0.9.0-3 :
+ A bug was introduced in 0.9.0-2 . The symbolic link to the erwiz script
+ wasn't set correctly.
+
+ * erwiz.changelog :
+ Added to keep track of changes.
+
+2011-09-01 Romain Schmitz <slopjong@hackerspace.lu>
+
+ * 0.9.0-2 :
+ Improved the install() and installing erwiz to
+ /usr/share/java/erwiz instead of /usr/share/java/erwiz-<pkgver>
+
+ * depends :
+ Changed the java dependency from openjdk6 to java-runtime.
+
+2011-09-01 Romain Schmitz <slopjong@hackerspace.lu>
+
+ * 0.9.0-1 :
+ Initial release.