summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a0ca09b46c3..7b8d98b976a0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = eslint-plugin-react
pkgdesc = React specific linting rules for ESLint
- pkgver = 6.10.0
+ pkgver = 7.12.3
pkgrel = 1
url = https://github.com/yannickcr/eslint-plugin-react
arch = any
@@ -8,9 +8,9 @@ pkgbase = eslint-plugin-react
makedepends = npm
depends = nodejs
depends = eslint
- noextract = eslint-plugin-react-6.10.0.tgz
- source = http://registry.npmjs.org/eslint-plugin-react/-/eslint-plugin-react-6.10.0.tgz
- md5sums = a289079092ec8da83f49933a6100651f
+ noextract = eslint-plugin-react-7.12.3.tgz
+ source = http://registry.npmjs.org/eslint-plugin-react/-/eslint-plugin-react-7.12.3.tgz
+ md5sums = 098736f2d96dac31f0e4fe8eb809c7b1
pkgname = eslint-plugin-react
diff --git a/PKGBUILD b/PKGBUILD
index 649c59a890f3..344df50084b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
-# Maintainer: Adrian Sinclair <adrian@transloadit.com>
+# Maintainer: Andrew Steinke <rkcf@rkcf.me>
+# Contributor: Adrian Sinclair <adrian@transloadit.com>
pkgname=eslint-plugin-react
-pkgver=6.10.0
+pkgver=7.12.3
pkgrel=1
pkgdesc='React specific linting rules for ESLint'
arch=('any')
@@ -11,11 +12,10 @@ depends=('nodejs' 'eslint')
makedepends=('npm')
source=(http://registry.npmjs.org/$pkgname/-/$pkgname-$pkgver.tgz)
noextract=($pkgname-$pkgver.tgz)
-md5sums=('a289079092ec8da83f49933a6100651f')
+md5sums=('098736f2d96dac31f0e4fe8eb809c7b1')
package() {
npm install -g --user root --prefix "$pkgdir"/usr "$srcdir"/$pkgname-$pkgver.tgz
- rm -r "$pkgdir"/usr/etc
# Fix permissions
find "$pkgdir/usr" -type d -exec chmod 755 '{}' +