summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD9
-rw-r--r--espanso-wayland.install7
3 files changed, 8 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 154c7fa26e09..b7e174ba4538 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
-pkgbase = espanso-wayland
+pkgbase = espanso
pkgdesc = Cross-platform Text Expander written in Rust
pkgver = 2.1.4
pkgrel = 1
url = https://espanso.org/
- install = espanso-wayland.install
arch = x86_64
license = GPL3
makedepends = rust
@@ -11,14 +10,13 @@ pkgbase = espanso-wayland
makedepends = cmake
makedepends = cargo-make
makedepends = rust-script
+ depends = xdotool
+ depends = xclip
+ depends = libxtst
depends = libnotify
depends = wxgtk2
- depends = libxkbcommon
- depends = wl-clipboard
- provides = espanso
- conflicts = espanso
options = !lto
source = git+https://github.com/federico-terzi/espanso.git#tag=v2.1.4-beta
sha512sums = SKIP
-pkgname = espanso-wayland
+pkgname = espanso
diff --git a/PKGBUILD b/PKGBUILD
index cbea9fa5f7de..90932686ef48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,16 @@
# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
_pkgver=2.1.4-beta
-pkgname=espanso-wayland
+pkgname=espanso
pkgver=2.1.4
pkgrel=1
pkgdesc="Cross-platform Text Expander written in Rust"
arch=(x86_64)
url="https://espanso.org/"
license=("GPL3")
-depends=("libnotify" "wxgtk2" "libxkbcommon" "wl-clipboard")
+depends=("xdotool" "xclip" "libxtst" "libnotify" "wxgtk2")
makedepends=("rust" "git" "cmake" "cargo-make" "rust-script")
-provides=("${pkgname%-wayland}")
-conflicts=("${pkgname%-wayland}")
options=("!lto") # fails with LTO as of 2022-03
-install=espanso-wayland.install
source=("git+https://github.com/federico-terzi/espanso.git#tag=v${_pkgver}")
sha512sums=('SKIP')
@@ -29,7 +26,7 @@ prepare() {
build() {
cd "espanso"
- cargo make --env NO_X11=true --profile release build-binary
+ cargo make --profile release build-binary
}
package() {
diff --git a/espanso-wayland.install b/espanso-wayland.install
deleted file mode 100644
index 9b273ae6f95d..000000000000
--- a/espanso-wayland.install
+++ /dev/null
@@ -1,7 +0,0 @@
-function post_install {
- setcap "cap_dac_override+p" /usr/bin/espanso
-}
-
-function post_upgrade() {
- post_install "$1"
-}