aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
2 files changed, 5 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1fb576293dbe..492a38d9f608 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ess-epics
pkgdesc = Experimental Physics and Industrial Control System -- ESS flavour
- pkgver = 2.0.3.r8.gb4369db
+ pkgver = 2.0.3
pkgrel = 1
url = http://www.aps.anl.gov/epics/
arch = any
@@ -14,12 +14,9 @@ pkgbase = ess-epics
depends = python-gitlab
depends = python-yaml
depends = python-gitpython
- depends = python-pathlib
- depends = python-argparse
- depends = python-pytest
provides = epics
conflicts = epics
- source = git+https://gitlab.esss.lu.se/e3/e3.git
+ source = git+https://gitlab.esss.lu.se/e3/e3.git#tag=2.0.3
md5sums = SKIP
pkgname = ess-epics
diff --git a/PKGBUILD b/PKGBUILD
index 0a952712685c..6805caeb15af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Grey Christoforo <first name at last name dot net>
pkgname=ess-epics
-pkgver=2.0.3.r8.gb4369db
+pkgver=2.0.3
pkgrel=1
pkgdesc="Experimental Physics and Industrial Control System -- ESS flavour"
arch=('any')
@@ -11,17 +11,12 @@ provides=('epics')
conflicts=('epics')
license=('GPL')
makedepends=('rpcsvc-proto' 'tree' 'git' 'python-build' 'python-installer' 'python-wheel')
-depends=('python-gitlab' 'python-yaml' 'python-gitpython' 'python-pathlib' 'python-argparse' 'python-pytest')
-source=("git+https://gitlab.esss.lu.se/e3/e3.git")
+depends=('python-gitlab' 'python-yaml' 'python-gitpython')
+source=("git+https://gitlab.esss.lu.se/e3/e3.git#tag=${pkgver}")
md5sums=('SKIP')
MAKEFLAGS="-j1" # mutithread building breaks this
-pkgver() {
- cd e3
- git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
- #printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
build() {
cd e3