summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
-rw-r--r--eusoft-ting-fr.sh5
3 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8778eedec17a..18b3f9ca9467 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = eusoft-ting-fr-bin
pkgdesc = 听力统计、笔记同步、语音高亮跟随,让您轻松愉快学法语
pkgver = 9.7.0
- pkgrel = 4
+ pkgrel = 5
url = https://www.frdic.com/ting
arch = x86_64
license = LicenseRef-custom
- depends = hicolor-icon-theme
depends = electron11-bin
conflicts = eusoft-ting-fr
conflicts = eudic-ting_fr
@@ -15,6 +14,6 @@ pkgbase = eusoft-ting-fr-bin
source = eusoft-ting-fr.sh
sha256sums = efbf72d55838f72fe4992330092473416476bb32ab6a0d03135aff64f99e74c9
sha256sums = 12ec1b3e4be99eee9c2d5fb55c196d2294c1b112e137927c61f81efb0e308f75
- sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
pkgname = eusoft-ting-fr-bin
diff --git a/PKGBUILD b/PKGBUILD
index 49943a76ea3b..f2b9b40403ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,13 @@ pkgname="eusoft-${_pkgname//_/-}-bin"
_zhsname="每日法语听力"
pkgver=9.7.0
_electronversion=11
-pkgrel=4
+pkgrel=5
pkgdesc="听力统计、笔记同步、语音高亮跟随,让您轻松愉快学法语"
arch=('x86_64')
url="https://www.frdic.com/ting"
license=('LicenseRef-custom')
conflicts=("${pkgname%-bin}" "eudic-${_pkgname}" "${_pkgname}")
depends=(
- 'hicolor-icon-theme'
"electron${_electronversion}-bin"
)
source=(
@@ -21,11 +20,12 @@ source=(
)
sha256sums=('efbf72d55838f72fe4992330092473416476bb32ab6a0d03135aff64f99e74c9'
'12ec1b3e4be99eee9c2d5fb55c196d2294c1b112e137927c61f81efb0e308f75'
- '50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data."*
sed "s|\"/opt/${_zhsname}/${_pkgname}\"|${pkgname%-bin}|g;s|Icon=${_pkgname}|Icon=${pkgname%-bin}|g" \
diff --git a/eusoft-ting-fr.sh b/eusoft-ting-fr.sh
index 86cb3dc6a9bf..7ddcaab8d734 100644
--- a/eusoft-ting-fr.sh
+++ b/eusoft-ting-fr.sh
@@ -2,6 +2,7 @@
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
@@ -9,7 +10,7 @@ export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file