summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD37
-rw-r--r--evalvid-compile-fixes.patch47
3 files changed, 105 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fff1ee786272
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by makepkg 5.0.2
+# Tue Aug 15 18:53:37 UTC 2017
+pkgbase = evalvid
+ pkgdesc = A framework and tool-set for evaluation of the quality of video transmitted over a real or simulated communication network.
+ pkgver = 2.7
+ pkgrel = 1
+ url = http://www2.tkn.tu-berlin.de/research/evalvid/fw.html
+ arch = x86_64
+ license = unknown
+ makedepends = gpac
+ depends = openssl
+ depends = libpng
+ depends = libjpeg-turbo
+ noextract = evalvid-2.7.tar.bz2
+ source = http://www2.tkn.tu-berlin.de/research/evalvid/EvalVid/evalvid-2.7.tar.bz2
+ source = evalvid-compile-fixes.patch
+ sha256sums = 9f4872f218427fe10560400a73144fc0be5d7a003429294190bbf00dc0866692
+ sha256sums = 825c4622049cacbefd1d15ae20804ba3b6ef31e366124a331f3fbff774a33822
+
+pkgname = evalvid
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6265ebd0497
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Sergio Correia <sergio@correia.cc>
+
+pkgname=evalvid
+pkgver=2.7
+pkgrel=1
+pkgdesc="A framework and tool-set for evaluation of the quality of video transmitted over a real
+or simulated communication network."
+url="http://www2.tkn.tu-berlin.de/research/evalvid/fw.html"
+license=('unknown')
+arch=('x86_64')
+depends=('openssl' 'libpng' 'libjpeg-turbo')
+makedepends=('gpac')
+source=("http://www2.tkn.tu-berlin.de/research/evalvid/EvalVid/${pkgname}-${pkgver}.tar.bz2"
+ evalvid-compile-fixes.patch)
+noextract=("${pkgname}-${pkgver}.tar.bz2")
+sha256sums=('9f4872f218427fe10560400a73144fc0be5d7a003429294190bbf00dc0866692'
+ '825c4622049cacbefd1d15ae20804ba3b6ef31e366124a331f3fbff774a33822')
+
+prepare() {
+ mkdir -p "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}"/"${pkgname}"-"${pkgver}"
+ tar xf ../${pkgname}-${pkgver}.tar.bz2
+ patch -uNp1 -i ../evalvid-compile-fixes.patch
+}
+
+build() {
+ cd "${srcdir}"/"${pkgname}"-"${pkgver}"
+ make
+}
+
+package() {
+ cd "${srcdir}"/"${pkgname}"-"${pkgver}"
+ mkdir -p "${pkgdir}/usr/bin"
+ make INSTDIR="${pkgdir}/usr/bin" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/evalvid-compile-fixes.patch b/evalvid-compile-fixes.patch
new file mode 100644
index 000000000000..64b9715ef89d
--- /dev/null
+++ b/evalvid-compile-fixes.patch
@@ -0,0 +1,47 @@
+diff --git a/Makefile b/Makefile
+index 5f035e6..2faa337 100644
+--- a/Makefile
++++ b/Makefile
+@@ -4,17 +4,17 @@ OBJ=$(SRC:.c=.o)
+ PRF=-pg
+ COP=-W -Wall -Wno-sign-compare -Wno-multichar -Wno-pointer-sign -Wno-parentheses -Wno-missing-field-initializers -Wno-missing-braces -O3
+ DST=mp4trace etmp4 psnr hist mos miv eg vsgen
+-INSTDIR=/usr/local/bin
++LDFLAGS=-lpthread -lgpac_static -lz -lm -lpng -ljpeg -lssl -lcrypto
+
+ all: $(DST)
+
+ mp4trace: bits.o error.o lock.o misc.o queue.o socket.o thread.o timing.o mp4trace.o
+ @echo L $@ ...
+- @$(CC) $^ -o $@ -lpthread -lgpac_static
++ @$(CC) $^ -o $@ ${LDFLAGS}
+
+ etmp4: bits.o misc.o read.o stat.o writemp4.o etmp4.o
+ @echo L $@ ...
+- @$(CC) $^ -o $@ -lgpac_static -lm
++ @$(CC) $^ -o $@ ${LDFLAGS}
+
+ psnr: psnr.o
+ @echo L $@ ...
+@@ -38,7 +38,7 @@ eg: misc.o random.o read.o eg.o
+
+ vsgen: vsgen.o
+ @echo L $@ ...
+- @$(CC) $^ -o $@
++ @$(CC) $^ -o $@ -lm
+
+ %.o: %.c
+ @echo C $< ...
+diff --git a/types.h b/types.h
+index 0b26e8b..228b86a 100644
+--- a/types.h
++++ b/types.h
+@@ -7,7 +7,7 @@
+ typedef SOCKET sock_t;
+ #elif defined(__linux__)
+ typedef int sock_t;
+- typedef unsigned long long u64;
++#include <gpac/setup.h>
+ #else
+ #include <stdint.h>
+ typedef int sock_t;