summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD48
2 files changed, 28 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5e577666712..5579a2bc03ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,9 @@
pkgbase = evilvte-git
- pkgdesc = VTE based, highly customizable terminal emulator.
+ pkgdesc = VTE based, highly customizable terminal emulator
pkgver = 150.8dfa41e
pkgrel = 6
- url = http://www.calno.com/evilvte/
- arch = i686
- arch = x86_64
+ url = http://www.calno.com/evilvte
+ arch = any
license = GPL2
makedepends = git
makedepends = pkg-config
@@ -12,8 +11,7 @@ pkgbase = evilvte-git
depends = vte-legacy
provides = evilvte
conflicts = evilvte
- source = evilvte::git://github.com/caleb-/evilvte.git#branch=master
- sha256sums = SKIP
+ source = git+https://github.com/caleb-/evilvte.git
+ sha512sums = SKIP
pkgname = evilvte-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 0c522ebd4cd4..19d79401f780 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,22 @@
# Contributor: ledti <antegist at gmail.com>
-# Maintainer: Stefan Husmann <Stefan-Husmann@t-online.de>
-
-pkgname=evilvte-git
-_pkgname=evilvte
+# Contributor: Stefan Husmann <Stefan-Husmann@t-online.de>
+_base=evilvte
+pkgname=${_base}-git
pkgver=150.8dfa41e
pkgrel=6
-pkgdesc='VTE based, highly customizable terminal emulator.'
-arch=('i686' 'x86_64')
-url="http://www.calno.com/evilvte/"
-license=('GPL2')
-depends=('hicolor-icon-theme' 'vte-legacy')
-makedepends=('git' 'pkg-config')
-provides=('evilvte')
-conflicts=('evilvte')
-source=("$_pkgname::git://github.com/caleb-/evilvte.git#branch=master")
-sha256sums=('SKIP')
+pkgdesc="VTE based, highly customizable terminal emulator"
+arch=(any)
+url="http://www.calno.com/${_base}"
+license=(GPL2)
+depends=(hicolor-icon-theme vte-legacy)
+makedepends=(git pkg-config)
+provides=(${_base})
+conflicts=(${_base})
+source=(git+https://github.com/caleb-/${_base}.git)
+sha512sums=('SKIP')
pkgver() {
- cd "$srcdir/$_pkgname"
+ cd ${_base}
echo $(git rev-list --count master).$(git rev-parse --short master)
}
@@ -25,23 +24,22 @@ prepare() {
# copy config.h to startdir to ease configuration:
cd "$startdir"
if [[ -e config.h ]]; then
- cp -f config.h "$srcdir/$_pkgname/src/"
+ cp -f config.h "$srcdir/${_base}/src/"
echo "To reset your configuration, remove $startdir/config.h"
else
- cp "$srcdir/$_pkgname/src/config.h" config.h
+ cp "$srcdir/${_base}/src/config.h" config.h
echo "Edit $startdir/config.h and recompile to change your settings."
fi
- }
+}
-build(){
-LANG=C
- cd "$srcdir/$_pkgname"
- ./configure --prefix=/usr --with-gtk=2.0
+build() {
+ LANG=C
+ cd ${_base}
+ ./configure --prefix=/usr --with-gtk=2.0
make
}
-package(){
- cd "$srcdir/$_pkgname"
+package() {
+ cd ${_base}
make DESTDIR="$pkgdir" install
}
-