summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD23
-rw-r--r--evolus-pencil-mime.xml10
-rw-r--r--pencil.desktop (renamed from evolus-pencil.desktop)5
5 files changed, 41 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 56a323fbdbf1..5e0a8717893f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,22 @@
pkgbase = evolus-pencil-bin
pkgdesc = An open-source GUI prototyping tool - Evolus release
- pkgver = 3.0.0_rc.1
+ pkgver = 3.0.0_rc.2
pkgrel = 1
url = http://pencil.evolus.vn/Next.html
arch = x86_64
license = GPL2
makedepends = binutils
makedepends = tar
+ depends = gconf
provides = evolus-pencil
conflicts = evolus-pencil
conflicts = pencil
- source = https://github.com/evolus/pencil/releases/download/v3.0.0-rc.1/Pencil-3.0.0-rc.1.deb
- source = evolus-pencil.desktop
- sha1sums = 3773688558231bf3f25bf33e0ebce8d6619c100d
- sha1sums = 8844653d3ce22669ef18d818ff986f317caf78ca
+ source = https://github.com/evolus/pencil/releases/download/v3.0.0-rc.2/Pencil_3.0.0-rc.2_amd64.deb
+ source = pencil.desktop
+ source = evolus-pencil-mime.xml
+ sha1sums = c988cfebc546e996d63925e44bdb2ddf122e35c8
+ sha1sums = 2c110cd29bc6cc421c1e649631c329d69c87a556
+ sha1sums = 975e4818189aa041bfe4df6e20c69d82cd130298
pkgname = evolus-pencil-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c8478afed3c6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+/pkg
+/src
+/tmp
+
+/*.deb
+/*.tar
diff --git a/PKGBUILD b/PKGBUILD
index 36f44cb2c826..52390fc7ee16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@ _binname=Pencil
_pkgname_base=pencil
_pkgname=evolus-pencil
_version=3.0.0
-_release=rc.1
-_zipname="${_binname}-${_version}-${_release}.deb"
+_release=rc.2
+_zipname="${_binname}_${_version}-${_release}_amd64.deb"
pkgname=${_pkgname}-bin
pkgver=${_version}_${_release}
pkgrel=1
@@ -13,14 +13,16 @@ pkgdesc="An open-source GUI prototyping tool - Evolus release"
arch=('x86_64')
url="http://pencil.evolus.vn/Next.html"
license=('GPL2')
-depends=()
+depends=('gconf')
makedepends=('binutils' 'tar')
provides=($_pkgname)
conflicts=($_pkgname $_pkgname_base)
source=("https://github.com/evolus/$_pkgname_base/releases/download/v${_version}-$_release/$_zipname"
- "$_pkgname.desktop")
-sha1sums=('3773688558231bf3f25bf33e0ebce8d6619c100d'
- '8844653d3ce22669ef18d818ff986f317caf78ca')
+ "${_pkgname_base}.desktop"
+ "${_pkgname}-mime.xml")
+sha1sums=('c988cfebc546e996d63925e44bdb2ddf122e35c8'
+ 'fd1a937f77388e46917fa566000acd89c5d181c3'
+ '975e4818189aa041bfe4df6e20c69d82cd130298')
package() {
# Extract data
@@ -31,13 +33,16 @@ package() {
# Binary file
install -d "${pkgdir}/usr/bin/"
- ln -s "../share/${_pkgname}/${_binname}" "${pkgdir}/usr/bin/${_pkgname_base}"
+ ln -s "../share/${_pkgname}/${_pkgname_base}" "${pkgdir}/usr/bin/${_pkgname_base}"
# Desktop file
- cp -L "${srcdir}/${_pkgname}.desktop" "${pkgdir}/usr/share/applications/"
+ cp -f "${srcdir}/${_pkgname_base}.desktop" "${pkgdir}/usr/share/applications/"
+
+ # Mimetype file
+ install -d "${pkgdir}/usr/share/mime/packages/"
+ cp "${srcdir}/${_pkgname}-mime.xml" "${pkgdir}/usr/share/mime/packages/"
# Cleanup
rm -rf "${pkgdir}/opt"
rm -rf "${pkgdir}/usr/share/doc"
- rm "${pkgdir}/usr/share/applications/${_binname}.desktop"
}
diff --git a/evolus-pencil-mime.xml b/evolus-pencil-mime.xml
new file mode 100644
index 000000000000..7faf22dea5c1
--- /dev/null
+++ b/evolus-pencil-mime.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
+ <mime-type type="application/x-evolus-pencil">
+ <comment>Evolus Pencil Document</comment>
+ <icon name="image-x-generic"/>
+ <glob pattern="*.ep"/>
+ <glob pattern="*.epz"/>
+ <glob pattern="*.epgz"/>
+ </mime-type>
+</mime-info>
diff --git a/evolus-pencil.desktop b/pencil.desktop
index 74312b47184b..c18a39970c3d 100644
--- a/evolus-pencil.desktop
+++ b/pencil.desktop
@@ -3,12 +3,13 @@ Encoding=UTF-8
Name=Pencil
Comment=Sketching and GUI prototyping tool
Comment[cs]=Nástroj na kreslení a prototypování GUI
+Comment[el]=Εργαλείο σχεδιασμού και κατασκευής πρωτοτύπων γραφικού περιβάλλοντος διεπαφής χρήστη
Comment[es]=Herramienta de esbozado y prototipado de interfaces gráficas de usuario
Comment[vi_VN]=Công cụ phát thảo giao diện Pencil
Exec=/usr/bin/pencil %f
Terminal=false
Type=Application
StartupNotify=true
-Icon=Pencil
+Icon=pencil
Categories=Graphics;2DGraphics;Development;
-MimeType=application/epz;
+MimeType=application/x-evolus-pencil;