summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD43
-rw-r--r--evolus-pencil.desktop14
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..56a323fbdbf1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = evolus-pencil-bin
+ pkgdesc = An open-source GUI prototyping tool - Evolus release
+ pkgver = 3.0.0_rc.1
+ pkgrel = 1
+ url = http://pencil.evolus.vn/Next.html
+ arch = x86_64
+ license = GPL2
+ makedepends = binutils
+ makedepends = tar
+ provides = evolus-pencil
+ conflicts = evolus-pencil
+ conflicts = pencil
+ source = https://github.com/evolus/pencil/releases/download/v3.0.0-rc.1/Pencil-3.0.0-rc.1.deb
+ source = evolus-pencil.desktop
+ sha1sums = 3773688558231bf3f25bf33e0ebce8d6619c100d
+ sha1sums = 8844653d3ce22669ef18d818ff986f317caf78ca
+
+pkgname = evolus-pencil-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36f44cb2c826
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Leonidas Arvanitis <l.arvanitis@gmail.com>
+
+_binname=Pencil
+_pkgname_base=pencil
+_pkgname=evolus-pencil
+_version=3.0.0
+_release=rc.1
+_zipname="${_binname}-${_version}-${_release}.deb"
+pkgname=${_pkgname}-bin
+pkgver=${_version}_${_release}
+pkgrel=1
+pkgdesc="An open-source GUI prototyping tool - Evolus release"
+arch=('x86_64')
+url="http://pencil.evolus.vn/Next.html"
+license=('GPL2')
+depends=()
+makedepends=('binutils' 'tar')
+provides=($_pkgname)
+conflicts=($_pkgname $_pkgname_base)
+source=("https://github.com/evolus/$_pkgname_base/releases/download/v${_version}-$_release/$_zipname"
+ "$_pkgname.desktop")
+sha1sums=('3773688558231bf3f25bf33e0ebce8d6619c100d'
+ '8844653d3ce22669ef18d818ff986f317caf78ca')
+
+package() {
+ # Extract data
+ tar xJf "${srcdir}/data.tar.xz" -C "${pkgdir}/"
+
+ # Package files
+ mv "${pkgdir}/opt/$_binname" "${pkgdir}/usr/share/$_pkgname"
+
+ # Binary file
+ install -d "${pkgdir}/usr/bin/"
+ ln -s "../share/${_pkgname}/${_binname}" "${pkgdir}/usr/bin/${_pkgname_base}"
+
+ # Desktop file
+ cp -L "${srcdir}/${_pkgname}.desktop" "${pkgdir}/usr/share/applications/"
+
+ # Cleanup
+ rm -rf "${pkgdir}/opt"
+ rm -rf "${pkgdir}/usr/share/doc"
+ rm "${pkgdir}/usr/share/applications/${_binname}.desktop"
+}
diff --git a/evolus-pencil.desktop b/evolus-pencil.desktop
new file mode 100644
index 000000000000..74312b47184b
--- /dev/null
+++ b/evolus-pencil.desktop
@@ -0,0 +1,14 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Pencil
+Comment=Sketching and GUI prototyping tool
+Comment[cs]=Nástroj na kreslení a prototypování GUI
+Comment[es]=Herramienta de esbozado y prototipado de interfaces gráficas de usuario
+Comment[vi_VN]=Công cụ phát thảo giao diện Pencil
+Exec=/usr/bin/pencil %f
+Terminal=false
+Type=Application
+StartupNotify=true
+Icon=Pencil
+Categories=Graphics;2DGraphics;Development;
+MimeType=application/epz;