summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD30
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9d81e5a9dee6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = evolution-decsync
+ pkgdesc = DecSync Plugin for Evoulution. It syncs contact and calendars to a directory, which can be shared with syncthing or rsync
+ pkgver = git
+ pkgrel = 1
+ url = https://github.com/39aldo39/Evolution-DecSync
+ arch = x86_64
+ arch = i686
+ arch = armv7h
+ arch = aarch64
+ license = GPLv2
+ makedepends = cmake
+ makedepends = meson
+ makedepends = ninja
+ makedepends = vala
+ makedepends = git
+ depends = libgee
+ depends = json-glib
+ depends = evolution-data-server
+ depends = evolution
+ provides = evolution-decsync
+ source = git+https://github.com/39aldo39/Evolution-DecSync
+ sha256sums = SKIP
+
+pkgname = evolution-decsync
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe6035504ee6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Vasket <vasket at dismail dot de>
+
+pkgname="evolution-decsync"
+_pkgname="Evolution-DecSync"
+pkgbase="evolution-decsync"
+pkgver="git"
+pkgrel="1"
+pkgdesc="DecSync Plugin for Evoulution. It syncs contact and calendars to a directory, which can be shared with syncthing or rsync"
+arch=(x86_64 i686 armv7h aarch64)
+license=("GPLv2")
+url="https://github.com/39aldo39/${_pkgname}"
+depends=(libgee json-glib evolution-data-server evolution)
+makedepends=(cmake meson ninja vala git)
+provides=("evolution-decsync")
+
+source=("git+https://github.com/39aldo39/${_pkgname}")
+sha256sums=("SKIP")
+
+build() {
+ cd "${_pkgname}"
+ meson build
+ ninja -C build
+}
+
+package() {
+ cd "${_pkgname}"
+ DESTDIR="${pkgdir}" meson install -C build
+
+}
+