summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO53
-rw-r--r--PKGBUILD50
-rw-r--r--evolution.install19
3 files changed, 122 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..936b9ee99622
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,53 @@
+# Generated by makepkg 4.2.1
+# Mon Jun 8 17:15:06 UTC 2015
+pkgbase = evolution-git
+ pkgdesc = Manage your email, contacts and schedule
+ pkgver = 3.17.2.r27.g77897bc
+ pkgrel = 1
+ url = https://wiki.gnome.org/Apps/Evolution
+ install = evolution.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = intltool
+ makedepends = itstool
+ makedepends = docbook-xsl
+ makedepends = networkmanager
+ makedepends = highlight
+ makedepends = gnome-desktop
+ makedepends = evolution-data-server
+ makedepends = libcanberra
+ makedepends = libpst
+ makedepends = libytnef
+ makedepends = desktop-file-utils
+ makedepends = hicolor-icon-theme
+ makedepends = dconf
+ makedepends = gtkspell3
+ makedepends = webkitgtk
+ makedepends = libcryptui
+ depends = gnome-desktop
+ depends = evolution-data-server
+ depends = libcanberra
+ depends = libpst
+ depends = libytnef
+ depends = desktop-file-utils
+ depends = hicolor-icon-theme
+ depends = dconf
+ depends = gtkspell3
+ depends = libcryptui
+ depends = webkitgtk
+ depends = gtk-doc
+ depends = gnome-common
+ optdepends = highlight: text highlight plugin
+ optdepends = evolution-spamassassin: Spamassassin spam check plugin
+ optdepends = evolution-bogofilter: Bogofilter spam check plugin
+ provides = evolution
+ conflicts = evolution
+ replaces = evolution
+ options = !emptydirs
+ source = git://git.gnome.org/evolution
+ sha256sums = SKIP
+
+pkgname = evolution-git
+ groups = gnome-extra
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c4de15f61a42
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: <tmoore01 (at) gmail (dot) com>
+
+_pkgname=evolution
+pkgname=$_pkgname-git
+pkgver=3.17.2.r27.g77897bc
+pkgrel=1
+pkgdesc="Manage your email, contacts and schedule"
+arch=(i686 x86_64)
+license=(GPL)
+depends=(gnome-desktop evolution-data-server libcanberra libpst libytnef desktop-file-utils hicolor-icon-theme dconf gtkspell3 libcryptui webkitgtk gtk-doc gnome-common)
+makedepends=(intltool itstool docbook-xsl networkmanager highlight gnome-desktop evolution-data-server libcanberra libpst libytnef desktop-file-utils hicolor-icon-theme dconf gtkspell3 webkitgtk libcryptui)
+optdepends=('highlight: text highlight plugin'
+ 'evolution-spamassassin: Spamassassin spam check plugin'
+ 'evolution-bogofilter: Bogofilter spam check plugin')
+options=('!emptydirs')
+url="https://wiki.gnome.org/Apps/Evolution"
+conflicts=('evolution')
+replaces=('evolution')
+provides=('evolution')
+install=$_pkgname.install
+source=(git://git.gnome.org/evolution)
+sha256sums=('SKIP')
+
+build() {
+ cd $srcdir/$_pkgname
+
+ ./autogen.sh --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var \
+ --libexecdir=/usr/lib \
+ --enable-nss=yes \
+ --with-openldap=yes \
+ --enable-smime=yes \
+ --disable-schemas-compile \
+ --disable-autoar
+
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' -e 's/ if test "$export_dynamic" = yes && test -n "$export_dynamic_flag_spec"; then/ func_append compile_command " -Wl,-O1,--as-needed"\n func_append finalize_command " -Wl,-O1,--as-needed"\n\0/' libtool
+
+ make
+}
+
+pkgver() {
+ cd $srcdir/$_pkgname
+ git describe --long | sed 's/^EVOLUTION_//;s/\([^-]*-g\)/r\1/;s/-/./g;s/_/./g'
+}
+
+package() {
+ groups=('gnome-extra')
+ cd $srcdir/$_pkgname
+ make DESTDIR="$pkgdir" install
+}
diff --git a/evolution.install b/evolution.install
new file mode 100644
index 000000000000..67eca41f097a
--- /dev/null
+++ b/evolution.install
@@ -0,0 +1,19 @@
+post_install() {
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+}
+
+pre_upgrade() {
+ if [ -f /usr/share/gconf/schemas/evolution.schemas ]; then
+ gconfpkg --uninstall evolution
+ fi
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}